Commits

Anonymous committed 8c689d8

[svn r9726] 0.11.7.1: check against version [[pysqlite:wiki:1.1.7_Changelog|1.1.7]] of PySqlite, there was no version 1.0.7.

Comments (0)

Files changed (1)

trac/db/sqlite_backend.py

         if not have_pysqlite:
             self.error = _("Cannot load Python bindings for SQLite")
         elif sqlite_version >= 30303:
-            if sqlite.version_info < (1, 0, 7):
-                self.error = _("Need at least PySqlite 1.0.7 or higher")
+            if sqlite.version_info < (1, 1, 7):
+                self.error = _("Need at least PySqlite 1.1.7 or higher")
             elif sqlite.version_info[0] == 2 and \
                     sqlite.version_info < (2, 0, 7):
                 self.error = _("Need at least PySqlite 2.0.7 or higher")