Issue #8 resolved

Installation issue

Mikhail Matyunin
created an issue

Hello, i have some installation issues:

$ sudo pecl install event
Package "event" Version "1.10.2" does not have REST xml available
install failed

My env.:

$ php -v
PHP 5.5.9-1ubuntu4.2 (cli) (built: Jun 25 2014 17:17:37) 
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies
$ php -m
[PHP Modules]
...
libevent
...
$ uname -a
Linux ubuntu-trusty-64 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
$ cat /etc/issue
Ubuntu 14.04 LTS \n \l

Comments (2)

  1. Ruslan Osmanov repo owner

    Sorry for the late reply. Actually the PECL REST API has some weird issues with Unicode: http://pecl.php.net/rest/r/event/1.10.2.xml

    I've just uploaded event-1.10.3. The REST XML looks good now: http://pecl.php.net/rest/r/event/1.10.3.xml . However, sudo pecl install event still tries to install event-1.10.2 for some reason. I believe it'll be fixed shortly. Right now the following command should work though:

    sudo pecl install http://pecl.php.net/get/event-1.10.3.tgz
    

    Wtf? 0.1.0 is > than 0.0.2

    Just the event package conflicts with the libevent package, since both provide API to the same library - libevent. To use the event extension you should uninstall libevent (I mean the PECL extension, not the library!).

    Thanks.

  2. Log in to comment