Latest debian update breaks ros-hydro-gazebo3-ros-pkgs

Create issue
Issue #1222 closed
Elliot Salisbury created an issue

Recently there was an update in the package manager from gazebo 3.0.0-1 to gazebo 3.0.0-3.

this has now broken the gazebo to ros-hydro bridge.

When we run:

rosrun gazebo_ros gazebo

we get the following error:

gzserver: symbol lookup error: /opt/ros/hydro/lib/libgazebo_ros_paths_plugin.so: undefined symbol: _ZN3ros7package10getPluginsERKSsS2_RSt6vectorISsSaISsEE
gzclient: symbol lookup error: /opt/ros/hydro/lib/libgazebo_ros_paths_plugin.so: undefined symbol: _ZN3ros7package10getPluginsERKSsS2_RSt6vectorISsSaISsEE
/opt/ros/hydro/lib/gazebo_ros/gazebo: 25: kill: invalid signal number or name: SIGINT

Comments (11)

  1. Jose Luis Rivero

    The changes from gazebo-3.0.0-1 to gazebo-3.0.0-3 should not lead to get this problem. Maybe an update on ros hydro packages? I was not able to reproduce the issue.

  2. Elliot Salisbury reporter

    Hi, I am still getting this issue.

    I tried upgrading ros-hydro-ros-lib (there was 2 outstanding updates to be applied) but it had no effect.

    I have recreated the issue by:

    1. starting from a fresh ubuntu 12.04 install
    2. installing ros-hydro-desktop-full
    3. installing gazebo3
    4. installing ros-hydro-gazebo3-ros-pkgs
    5. then try executing rosrun gazebo_ros gazebo

    Perhaps I'm installing the wrong packages, how is it supposed to be set up?

  3. Jose Luis Rivero

    I'm reviewing this issue and I'm able to reproduce it now in my precise chroot.

    My diagnostic is:

    We have to re-release the gazebo3 ROS wrappers to fix this problem but I want to fix our internal ABI detector first.

  4. Jose Luis Rivero

    I've rebuilt the gazebo3 ROS Hydro wrappers (only for precise), could you please give a try to the our new repository version 2.4.2-5 and see if it solves the problem for you?

    Thanks

  5. Elliot Salisbury reporter

    Thanks Jose,

    I've tried it out and can confirm that gazebo3 ros hydro wrappers now work.

    Elliot

  6. Log in to comment