Issue #1514 new
Carlos Agüero created an issue

Just click on "File->Save World As".

The pop-up windows appears empty.

This is happening in default running on Ubuntu Trusty.

Comments (21)

  1. Louise Poubel

    A similar bug happens sometimes (can't seem to reproduce now though) on the Model Editor. Click on Add then Browse and a blank dialog pops up. Try to Save and then Browse and a blank dialog pops up.

  2. RDaneelOlivaw

    I'm useing Gazebo5 and I have this exact same error. When save_as a world it popos up a blanc window.
    Any idea how it could be solved?

  3. Sean Kugele

    I also encountered a similar issue using Gazebo 5.1.0 on Ubuntu 14.04.

    Running gzclient as root corrected the issue for me, so it may be permissions related?

  4. Louise Poubel

    @sean_kugele , was your issue with the Import Image dialog in the Building Editor? A fix for that has been backported to Gazebo5 but there might have been no releases since. @Steven Peters , can you confirm on the release?

    If it was another dialog then it might be an unknown issue.

  5. Sean Kugele

    Thank you for the quick responses.

    This issue was not limited to the Building Editor "import". All of the file browsers were affected.

    I was able to track down the root cause to settings in my ".config/Trolltech.conf". In particular, having "style=GTK+" in Trolltech.conf broke the file browsers. Removing it fixed the issue.

    As a side note, the Building Editor "import" functionality is working fine for me after the configuration changes.

    Thanks again. I'm very impressed by how quickly you guys responded to my original comment. Kudos!

  6. Mirs King

    I also met the same problem, empty save-as dialog. I'm using gazebo 5.1.0 and ubuntu 14.04.
    In my .config/Trolltech.conf, there isn't any "style=GTK+" .

  7. Laughlin Barker

    Confirm on gazebo 2.2.3, Ubuntut 14.04 (virtualBox, 3D accel on, no guest additions, but extension pack installed, software OpenGL).

  8. Log in to comment