[Gazebo9] Video Plugin Crashes Gzserver

Issue #2501 invalid
Arif Rahman created an issue

Hello all,

It seems that the video plugin libgazebo_ros_video.so is crashing gzserver everytime I load it in ROS Kinetic + Gazebo 9.

This is the code snippet:
``` <gazebo reference="screen">

<visual>

  <plugin name="screen_video_controller" filename="libgazebo_ros_video.so">

    <height>600</height>

    <width>1024</width>

    <topicName>/robot/head_display</topicName>

    <robotNamespace>/robot</robotNamespace>

  </plugin>

</visual>

</gazebo>

If I try to load this model, I'll get:
```[ INFO] [1533119655.853751756]: GazeboRosVideo (gzclient, ns = /robot) has started

Segmentation fault (core dumped)

[gazebo_gui-3] process has died [pid 12932, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/arif/.ros/log/6157ef48-9576-11e8-90e1-6c71d97cbaff/gazebo_gui-3.log].
log file: /home/arif/.ros/log/6157ef48-9576-11e8-90e1-6c71d97cbaff/gazebo_gui-3*.log

But if I comment out that part, it loads ok (without that video display, of course).

I understand that in Gazebo 7 it was outputting a warning https://bitbucket.org/osrf/gazebo/issues/2202/gazebo7-visualplugins-are-deprecated , but in my Gazebo 9 it just crashes.

Can anyone help?

Comments (3)

  1. Shane Loretz

    Hi @Arif Rahman , Since this is a crash coming from a gazebo plugin I think it would fit better as an issue at the gazebo_ros_pkgs repo where plugins like libgazebo_ros_video.so come from. This repo is for the gazebo simulator itself.

    Would you mind creating an issue there? I'll close this for now, but would be happy to reopen it if it turns out to be an issue here.

  2. Log in to comment