Added GpuLaserDataIterator to replace some magic numbers

#2637 Merged at 0c19dc2
Repository
Branch
GpuLaserDataIterator
Repository
Branch
default
Author
  1. Shane Loretz
Reviewers
Description

By adding an iterator this removes the requirement to know some implementation details of GpuLaser in order to get data from it. It removes a couple magic numbers that were being used in GpuRaySensor when using the data.

  • Deprecates float* GpuLaser::LaserData()
  • Adds DataIter GpuLaser::LaserDataBegin()
  • Adds DataIter GpuLaser::LaserDataEnd()

Comments (8)

  1. Ian Chen

    Nice, I think it's going to make the GpuLaser API easier to use. I made a few coding style suggestions so we can keep the style consistent across the files in this repo.

  2. Ian Chen

    looks good to me, just one minor comment about a debug message otherwise it's good to go