1. otsug
  2. Yapan
  3. Issues
Issue #6 open


Anonymous created an issue

Would it be possible to support Yakuake? Because an update command like this {{{


qdbus org.kde.yakuake /yakuake/sessions addSession; qdbus org.kde.yakuake /yakuake/window toggleWindowState; qdbus org.kde.yakuake /yakuake/sessions runCommand "%1; echo && echo --- Finished ---"; }}} does not work.

Comments (3)

  1. otsug repo owner

    Hmm, I did traied before; run yapan in yakuake without success, but at the time I didn't know about this commands, apparently if you put this one line:

    qdbus org.kde.yakuake /yakuake/sessions addSession && qdbus org.kde.yakuake /yakuake/window toggleWindowState && qdbus org.kde.yakuake /yakuake/sessions runCommand "bash -c \"%1; echo && echo --- Finished ---\""

    in the update command to call will work, thank you.

  2. Anonymous

    Hello, I'm not the one who originally posted the issue but I've tried it too. Leaving all the defaults options and changing the "Update command to call" as you said doesn't work (when you right-click>Update the icon, it keeps moving as if it were syncronizing for a while and no Yakuake session is open neither does the window drop-down as it should). By running the command manually in Konsole, a new Yakuake tab is opened and the window is dropped-downed but I get the message (in the Yakuake window):

    error: you cannot perform this operation unless you are root.
    --- Finished ---

    By comparing the original "Command to update" with the proposed version for Yakuake I'm gessing a "su -l root" is missing somewhere but I tried adding it in several places without success :P. So, in summary there are two bugs with the command for Yakuake: 1-Doesn't work when you right-click>Update (icon keeps moving and Yakuake doesn't open). 2-Even if you use it manually from Konsole, it denies permission if you aren't root instead of prompting for password. Thanks a lot in advance :P, sorry for my horrible english.

  3. Anonymous

    PS (I'm the one who posted last): I'm using Arch x86_64, KDE 4.7, Konsole 4.7.0-1, Yakuake 2.9.8-1 and Yapan 0.4.1-1, all the latest versions available in the Arch repositories at the time of this writing.

  4. Log in to comment