pkg_resources is still required, unable to run on GAE

Issue #79 resolved
Yuen Ho Wong
created an issue

In tw.core b4, template.py is blatantly importing pkg_resources in the first line, and tw.core.init.py loads template.py so in effect every import of tw.core tries to import pkg_resources.

This issue makes tw2 unable to run on Google App Engine.

Comments (2)

  1. Ralph Bean

    We looked at this during the tw2 bugsprint on March 3rd and determined that it won't be easy to extricate tw2 from pkg_resources. We use it to collect resources from plugins, to find templates, to namespace our plugins.

    I'm sorry, but I think this means that we won't ever support Google App Engine.

    If anyone disagrees, please re-open this ticket and provide a patch.

  2. Log in to comment