Installable requirements

Issue #36 new
Reinaldo Astudillo
created an issue

Hi,

I was trying to install the package using pip/virtualenv from and I got an error about numpy dependency.

pip isn't detecting the requirements of pyevtk. I believe that should be an option in the setup.py file. For example, When one uses setuptools.setup, the option to set the requirements of a package is install_requires. Perhaps, there is a similar option for the function distutils.core.setup used in setup.py. Or maybe, the use of setuptools.setup is more convenient.

PD: I know that numpy is ubiquitous, however this suggestion is only to simplify the installation in virtualenv.

Thanks

Comments (1)

  1. Log in to comment