1. Peer Stritzinger
  2. hgcollapse
  3. Issues
Issue #6 new

unit tests failing on os x

Kevin Stanton
created an issue


I cloned hgcollapse on a Mac running Snow Leopard and Homebrew. I have hg 2.0.2 installed, and I ran the unit tests for hg collapse.

Two of them are failing:


!.................. Skipped test-empty-branch-commit.t: blacklisted Failed test-branch.t: output changed Failed test-hashchange.t: output changed

Ran 24 tests, 1 skipped, 2 failed.

make: *** [test] Error 1

}}} Is it safe to use hgcollapse if these tests are failing? They also failed when I tried it with hg 1.9.1 on a different machine...



Comments (3)

  1. Peer Stritzinger repo owner

    I'll try to reproduce this, meanwhile I have some questions for you:

    • You mention the same tests failing when you were using 1.9.1 ... are you sure you are using the most current version of hgcollapse since it would refuse to run with hg version < 2.0
    • Can you run hg sum in the clone of hgcollapse you are using for the tests?
    • Can you attach the error output of the failed tests (you can find these after you ran the tests in the test subdir of hgcollapse, same name as the failed tests but with .err appended.
  2. Log in to comment