1. Jon Nylander
  2. jsTimezoneDetect
  3. Issues

Issues

Issue #19 resolved

Australia/Melbourne?

superflycrazy
created an issue

When changing my Windows 7 system time to Australia/Melbourne (+10:00) this script breaks - undefined. I've googled all over for help on this. Melbourne is a critical timezone of our international members.

Is it as easy as creating a line after "600,0":["+10:00","Australia/Brisbane",!1],"600,1":["+10:00","Asia/Vladivostok",!0],"600,1,s":["+10:00","Australia/Sydney",!0], such as "600,2":["+10:00","Australia/Melbourne",!0] and changing !1 to !2, !0 to !1?

Please advise. Thx!

Comments (6)

  1. Jon Nylander repo owner

    (Reply via j...@pageloom.com):

    Thank you for reporting, I will take a look at this after the weekend.

    However. The script should result in Australia/Sydney for Melbourne. Without geolocation or IP lookups that's as close as it can get.

    So if you really get undefined when your computer is set to Melbourne. Than that's a bug. Hopefully one I can reproduce and resolve.

    Kind regards, Jon

  2. superflycrazy reporter

    That's correct, on Windows XP and Windows 7, when timezone is set to Melbourne it does not result in Sydney, which is sufficient for our use but instead it shows the js error "a is undefined" and shows as blank on our site. I appreciate your help.

    OH! Just discovered something interesting. I'm in the US so DST is selected usually on my system. The error occurs when selecting Melbourne with DST still selected. I guess Australia doesn't participate with daylight savings?

  3. Jon Nylander repo owner

    (Reply via j...@pageloom.com):

    I am not in a position to look deeper into the issue right now but will do so after the weekend. Definitely sounds like a bug.

    Thank you again.

    Regards, Jon

  4. Anonymous

    I was having the exact same issue on Mac OSX with both latest version of Chrome and Safari. I tried both minified, un-minified, problem was only solved when I downloaded the minified timezone.js file from the demonstration page and told my script to use that instead of the version(s) I downloaded from BitBucket.

  5. Log in to comment