1. Peter Sanchez
  2. django-impersonate

Pull requests

#10 Declined
Repository
django-impersonate
Branch
default

Add backwards-compatibility for Django 1.3.

Author
  1. todofixthis
Reviewers
Description

django-impersonate works great in Django 1.3, except when importing URLs because Django's urls module path changed in 1.4.

This patch adds BC for 1.3 by importing the 1.3 urls.defaults module if it fails to import the 1.4+ urls one.

  • Learn about pull requests

Comments (1)

  1. Peter Sanchez repo owner

    I don't mind this small change, but a few things are needed:

    1. We need the tox.ini updated to include testing for 1.3. All tests should pass there (I believe there is an .exists() call somewhere that doesn't function on 1.3, maybe I'm wrong)
    2. The README file should be updated as it states that Django 1.4+ is required.