Issue #45 new

sgi mpt is not directly supported by petsc

Anonymous created an issue

On sgi machine the mpi implementation provides only mpirun and not mpiexec. The problem is that petsc support only the syntax "mpirun -n" and sgi mpt only the syntax "mpirun -np". thus "make test" after whole compilation will never work !!

Comments (2)

  1. Jed Brown
    1. The MPI standard specifies an mpiexec startup command, with some standard options (but does not require it). The standard does not endorse mpirun in any way and indeed, mpirun arguments are not portable. (Some common implementations have since provided mpirun for convenience and made it behave like the standardized mpiexec.)

    2. If you are in a non-standard environment, then you should use --with-mpiexec=your-run-command.

  2. Log in to comment