Overview

PETSc for Python

Overview

Welcome to PETSc for Python. This package provides Python bindings for PETSc, the Portable, Extensible Toolkit for Scientific Computation.

Dependencies

  • A matching version of PETSc built with shared/dynamic libraries.
  • Python 2.4 to 2.7 or 3.1 to 3.4.
  • A recent NumPy release.
  • To work with the in-development version, you need to install Cython.