Insert or Edit Not Committing

Issue #331 new
Former user created an issue

I recently installed phpLiteAdmin 1.9.7.1. When I try to either insert or update a row in any table, I receive a "success" message; however, the row is not inserted or updated. Any ideas?

Comments (8)

  1. Rosemary Holt

    To clarify my issue: I updated phpLiteAdmin from 1.9.1 to 1.9.7.1. Prior to the upgrade, I was able to successfully insert, update, and delete rows. Thanks for any help!

  2. phpLiteAdmin repo owner

    Please check if the problem occurs for all tables and databases or if it is only happening with one or a couple of table. Please

    1. create a new db using phpLiteAdmin
    2. create a new very simple table using phpLiteAdmin with only 2 columns a and b, both of type Text
    3. try to insert some values

    If this works try if the same works in your original database.

    If both work, can you please post the CREATE TABLE statement of the table that does not work? Are there any foreign key constraints, triggers, or indexes on that table?

  3. Rosemary Holt

    Thanks for your quick response.

    Here is what I tried to do:

    1. Create a new db (called testdb). This "seemed" to work (see screenshot 1)

    2. Using the "Create New Table on Database testdb" section on the successful database creation screen, I tried to create tabletest1. Instead of creating the table on testdb, it tried to create the table on the original db, k9 (see screenshot 2)

    3. Even though a successful table created message was displayed, the table wasn't actually created (see screenshot 3)

    4. I clicked "Return" and neither the new database nor table are displayed (see screenshot 4)

    1 - After Database Create.jpg 2 - Create Table.jpg 3 - After Create Table Issued.jpg 4 - After Return.jpg

    Thanks again for any help in resolving this issue.

  4. phpLiteAdmin repo owner

    Have you checked if creating a table on testdb work?

    Is k9.sqlite an SQLite 3 or SQLite 2 database? I see from your screenshots that your PHP still supports both versions. There might be an issue that only affects SQLite 2 databases.

    You can check the SQLite version of your database file if you click on the "Structure" Tab of the DB. For your testdb, it says version 3.7.4 and SQLite extension "PDO". Does this look the same for k9.sqlite? Or does it say "SQLiteDatabase" as extension and 2.x as version?

  5. phpLiteAdmin repo owner

    Can you please set $debug=true in the config and try to create a table or insert data and post the output or give a screenshot?

  6. Rosemary Holt

    I turned $debug=true. Here are the results after 1 - logging into phpliteadmin; 2- trying to create a database; 3- trying to add a table to the test database; 4-trying to add columns to the test table; 5-final result (the database and table were not created) See associated screen shots.

    Thanks!

    1 - After Logging In.jpg

    2 - After trying to create database testdb2.jpg

    3 - After trying to create table on testdb2.jpg

    4 - Trying to add columns to table1 in testdb2.jpg

    5 - After trying to create columns on testdb2.jpg

  7. phpLiteAdmin repo owner

    sorry for the late reply. Last year I could not find much time for this project.

    This seemed to be some kind of permission problem, i.e. not enough file system permissions, probably on the database folder, not the database itself.

    Did you find some solution? Does the problem still persist?

  8. Log in to comment