Assure Compatability with Stash 3.0

Issue #27 resolved
Thiago Bomfim created an issue

With the release of Stash 3.0, all interfaces that were marked deprecated in Stash 2.11 and earlier will be removed completely. As a result, existing plugins that use any deprecated interfaces will not be automatically compatible with Stash 3.0 and that would be good if you can fix it for this release.

Your plugin was found to be currently incompatible with Stash 3.0. Below the documentation you should consult:

https://developer.atlassian.com/stash/docs/latest/reference/api-changelog.html#Stash_3.0

Stack trace:

SEVERE: Servlet.service() for servlet [plugins] in context with path [] threw exception [Servlet execution threw an exception]with root cause java.lang.NoSuchMethodError: com.atlassian.stash.repository.RepositoryService.findBySlug(Ljava/lang/String;Ljava/lang/String;)Lcom/atlassian/stash/repository/Repository; at com.pirateninjaunicorn.stash.readmeparser.util.RepositoryHelper.getCurrentRepository(RepositoryHelper.java:51) at com.pirateninjaunicorn.stash.readmeparser.servlet.ReadmeParserServlet.doPost(ReadmeParserServlet.java:102) at com.pirateninjaunicorn.stash.readmeparser.servlet.ReadmeParserServlet.doGet(ReadmeParserServlet.java:86) at javax.servlet.http.HttpServlet.service(HttpServlet.java:620) at javax.servlet.http.HttpServlet.service(HttpServlet.java:727) ... ...

Best regards, Thiago Bomfim Atlassian Support

Comments (5)

  1. Log in to comment