Issue #5 wontfix
eSolutions created an issue

Hi,

I'm not able to see the "Overview" tab in STASH

System configuration: STASH 2.0 on my iMac java version 1.6.0_37 git version 1.8.0.1 ReadMe Parser 1.1.1 Browser Safari, Google Chrome

My README.md file is located in the root folder of my project. I created the file using MOU and here everything looks just fine.

I have tried with readme.md, readme.markdown, README.md and README.markdown and still no luck.

In STASH I click on my project and then on my repository. Here I have the following options: [Files] [Commits] [Pull Requests] [Settings]

Comments (21)

  1. eSolutions reporter

    The README.md shows up at the bottom below all files but still not in it's own window using a Overview button.

  2. Micha Kops

    Hi Michael,

    thanks for filing this issue! The display of the readme at the bottom below all files is a feature that Atlassian has added in the latest Stash version so that's nothing rendered from our plugin.

    I think we'll have to investigate in the problem described above.

  3. Micha Kops

    Hi,

    the client side seems to be working on a Mac with Chrome as browser. So we ought to take a look at the server side and running the Stash instance on a Mac. Is there any update from your side? Do the log files provide some more detailed information?

    Best regards

    Micha

  4. eSolutions reporter

    Hi, no news from my side... I have also checked my logfiles but nothing about loading plugin here... if you need any other informations from me to get closer a solution just ask. Reason for running on my iMac is that I still have problems getting STASH started on my QNAP NAS (waiting for atlassian support to give me some feedback) but if I'm lucky and the installation on my NAS is starting to work I will test your plugin running on my NAS.

    Best regards Michael

  5. Micha Kops

    Ok I think we're going to run a stash instance on a mac and see if we're able to reproduce this error.

    Did you notice any Javascript errors? Are all components of the plugin activated (in the plugin administration area)?

    If you're modifying the loglevel in your log4j.properties e.g. by adding log4j.logger.com.pirateninjaunicorn=debug - do you see any specific output from the plugin?

    tia!

  6. eSolutions reporter

    Hi, Tried with Firefox also... same result. Also no JavaScript errors. I know about Java logging but could not find any log4j.properties file. Tried to add the line to logging.properties but could not find any new log files when loading the server again so that might not work.

    Tried to launch in foreground and the result is shown below... hope it helps... there are a few warnings but I don't know if they can crash your plugin :-)

    /Michael

    Michael-Thgersens-iMac:atlassian-stash-2.0.0 mth$ sh bin/start-stash.sh -fg -e Starting Atlassian Stash as current user

    Detecting JVM PermGen support... PermGen switch is supported. Setting to 256m

    Using STASH_HOME: /Users/mth/Documents/stash-data Using CATALINA_BASE: /Users/mth/Documents/atlassian-stash-2.0.0 Using CATALINA_HOME: /Users/mth/Documents/atlassian-stash-2.0.0 Using CATALINA_TMPDIR: /Users/mth/Documents/atlassian-stash-2.0.0/temp Using JRE_HOME: /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home Using CLASSPATH: /Users/mth/Documents/atlassian-stash-2.0.0/bin/bootstrap.jar:/Users/mth/Documents/atlassian-stash-2.0.0/bin/tomcat-juli.jar Using CATALINA_PID: /Users/mth/Documents/atlassian-stash-2.0.0/work/catalina.pid Dec 17, 2012 7:38:23 PM org.apache.catalina.core.AprLifecycleListener init INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: .:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java Dec 17, 2012 7:38:23 PM org.apache.tomcat.util.digester.SetPropertiesRule begin WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'xmlValidation' to 'false' did not find a matching property. Dec 17, 2012 7:38:23 PM org.apache.tomcat.util.digester.SetPropertiesRule begin WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'xmlNamespaceAware' to 'false' did not find a matching property. Dec 17, 2012 7:38:23 PM org.apache.coyote.AbstractProtocol init INFO: Initializing ProtocolHandler ["http-bio-7990"] Dec 17, 2012 7:38:23 PM org.apache.catalina.startup.Catalina load INFO: Initialization processed in 530 ms Dec 17, 2012 7:38:23 PM org.apache.catalina.core.StandardService startInternal INFO: Starting service Catalina Dec 17, 2012 7:38:23 PM org.apache.catalina.core.StandardEngine startInternal INFO: Starting Servlet Engine: Apache Tomcat/7.0.32 badgr.achievements.achievementsTabPane badgr.achievements.achievementsTabPane Dec 17, 2012 7:39:02 PM org.apache.coyote.AbstractProtocol start INFO: Starting ProtocolHandler ["http-bio-7990"] Dec 17, 2012 7:39:02 PM org.apache.catalina.startup.Catalina start INFO: Server startup in 39286 ms Dec 17, 2012 7:39:05 PM com.sun.jersey.server.impl.application.WebApplicationImpl _initiate INFO: Initiating Jersey application, version 'Jersey: 1.8-atlassian-6 03/12/2012 02:59 PM' Dec 17, 2012 7:39:05 PM com.sun.jersey.api.wadl.config.WadlGeneratorLoader loadWadlGenerator INFO: Loading wadlGenerator com.sun.jersey.server.wadl.generators.WadlGeneratorApplicationDoc Dec 17, 2012 7:39:05 PM com.sun.jersey.api.wadl.config.WadlGeneratorLoader loadWadlGenerator INFO: Loading wadlGenerator com.sun.jersey.server.wadl.generators.WadlGeneratorGrammarsSupport Dec 17, 2012 7:39:06 PM com.sun.jersey.api.wadl.config.WadlGeneratorLoader loadWadlGenerator INFO: Loading wadlGenerator com.atlassian.plugins.rest.doclet.generators.resourcedoc.AtlassianWadlGeneratorResourceDocSupport

  7. Micha Kops

    Thanks for your quick feedback! :) I don't see anything specific from our plugin in the log excerpt - perhaps our tests on the same target platform will give us a hint.

    Do you have any other plugins installed? And to which version of java does "/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home" point to?

  8. eSolutions reporter

    Hi, I have enabled the following plugins

    Atlassian Developer Toolbox ReadMe Parser Stash Commenter SVN Importer for Atlassian Stash

    /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home points to /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents

    /Michael

  9. Micha Kops

    Thanks! Since I've got no clue at the moment we could at least test if there's an interference with other plugins if the system tests on the Mac platform should fail :)

  10. TheresaH

    I installed all mentioned plugins in my stash installation (linux) and got the overview tab and the readme file as expected. I guess the issue might be the stash installation on Mac, so we should try this next.

  11. TheresaH

    Hi @thoeger69

    we just released a new plugin version 1.1.3 to fix another issue. Maybe this resolves your problem, too?

    Would you mind checking the new plugin version and giving us feedback how it works for you?

    Regards

    Theresa

  12. eSolutions reporter

    Hi,

    Just updated the plugin to 1.1.3 and it's still not working :-(

    Sorry....

    Regards Michael

  13. Andy Madge

    I'm getting the same issue - no Overview tab displayed.

    This is a new install of Stash 2.0.2 on Windows 2003, with ReadMe Parser 1.1.3

    Not sure if it's relevant but I'm running Stash from the command line, using the internal database (doing a trial of Stash).

  14. TheresaH

    Hi @Andy Madge , hi @thoeger69

    would you mind checking the logs for us again? There is a simple documentation on how to enable debug logging https://confluence.atlassian.com/display/STASH/Enabling+Stash+debug+logging for a running stash instance.

    E.g.

    curl -u admin -v -X PUT -d "" -H "Content-Type: application/json" http://localhost:7990/rest/api/latest/logs/logger/com.pirateninjaunicorn/debug
    

    Then open the root file list of your repository (the one which contains a readme file), which should produce some log entries in stash/home/log/atlassian-stash.log

    Your help is highly appreciated, thanks a lot!

    Theresa

  15. Log in to comment