Commits

Author Commit Message Labels Comments Date
Peter Hosey
Increased GrowlMail's version to 1.2.2.
Branches
maintenance-1.2
Peter Hosey
Deleted unnecessary log message.
Branches
maintenance-1.2
Rudy Richter
GrowlMail: stupid extra space
Branches
maintenance-1.2
Rudy Richter
GrowlMail: UUIDs for 10.6.4's Mail.app and Message.framework
Branches
maintenance-1.2
Peter Hosey
Creating 1.2 maintenance branch. No changes. Parent is the revision that tagged 1.2.1b5.
Branches
maintenance-1.2
Peter Hosey
Added tag 1.2.1b5 for changeset 08081c3654f0
Branches
default
Peter Hosey
Changed the group owner of the growlnotify executable and manpage from admin to wheel. This works around a PackageMaker bug (x-radar://problem/8074151) that caused the package contents to have the builder's user and group instead of what we said in the pmdoc.
Tags
1.2.1b5
Branches
default
Peter Hosey
Increased version to 1.2.1b5.
Branches
default
Peter Hosey
Burninate growlnotify's INSTALL.txt, thereby resolving the inaccurate installation advice reported by Matt Wynne on the discussion list.
Branches
default
Peter Hosey
Replaced growlnotify's install.sh file with an Installer package.
Branches
default
Peter Hosey
Added an icon for growlnotify, mainly for use in its Installer package.
Branches
default
Peter Hosey
Upgraded simple-mailer to revision [1f3f19a25320], integrating a patch from “pinchies” in Growl #121 to fix invalid and therefore blank-looking email messages from MailMe. May also improve transit reliability. Fixes Growl #121.
Branches
default
Peter Hosey
Added tag 1.2.1b4 for changeset 5f522737a563
Branches
default
Peter Hosey
Increased version to 1.2.1b4.
Tags
1.2.1b4
Branches
default
Peter Hosey
Fix an under-retention crash: Use retain + autorelease to prolong the life of this bridge, so that a coalescing display doesn't message a dead bridge object in the following compound statement.
Branches
default
Peter Hosey
Burninate use of KVO by GrowlDisplayWindowController to observe its bridge's notification. This is totally unnecessary and causes memory-management problems. Fixes the crash introduced by the leak fix (previous change).
Branches
default
Peter Hosey
Notification-display bridges own their window controllers, so having each window controller to retain its bridge (as introduced in [325018a38208]) leaks both. Fixing this. This introduces a crash, previously masked by the leak.
Branches
default
Peter Hosey
Make GrowlDisplayPlugin implement initWithBundle:, not init, to match how GrowlWebKitDisplayPlugin calls up to its superclass.
Branches
default
Peter Hosey
We probably should pass the base URL here. If this changes anything, it means that display styles can use relative paths to resources in their style bundles.
Branches
default
Peter Hosey
Creating an NSDate every time this method executes results in a pretty big spike in memory whenever a bunch of notifications come in at once. Use NSTimeIntervals instead for this.
Branches
default
Peter Hosey
Added tag 1.2.1b3 for changeset 90ee4e5f7fd4
Branches
default
Peter Hosey
Increased version to 1.2.1b3.
Tags
1.2.1b3
Branches
default
Peter Hosey
Robustify against tickets containing bundle IDs that aren't strings.
Branches
default
Peter Hosey
GrowlSafari: Robustify setDownloadFinished against a few potential exceptions. I just got a removeObjectForKey:nil exception when I pasted a URL into the Downloads window. Having no stack trace, I don't know that this was the cause, but it's certainly possible and good to fix.
Branches
default
Peter Hosey
Fix #118: Restore GrowlSafari's ability to reveal downloaded files in the Finder upon notification click.
Branches
default
Peter Hosey
Added a PackageMaker document for an Installer package to delete GrowlMail's installation receipt.
Branches
default
Peter Hosey
Fixed leaking click contexts when notifications fade out or are clicked, reported by Wim Leers.
Branches
default
Peter Hosey
Fixed leaking every GrowlApplicationTicket object on loading saved tickets.
Branches
default
Peter Hosey
Only notify when iTunes is not the active app. Fixes #111.
Branches
default
Peter Hosey
Ripped out polling code. GrowlTunes 1.2.1 will require iTunes 4.7 or later. Includes a couple of new strings, for the iTunes-too-old error message.
Branches
default
  1. Prev
  2. Next