Commits

Author Commit Message Labels Comments Date
Daniel Holth
support transactional ddl
Gerhard Häring
new release
Gerhard Häring
fixed default for PYSQLITE_EXPERIMENTAL
Gerhard Häring
Added tag 2.6.2 for changeset f70cc626f740
Gerhard Häring
completely disable backup functionality in order to be compilable with older SQLite releases
Tags
2.6.2
Gerhard Häring
Added tag 2.6.1 for changeset 869264aaa293
Gerhard Häring
apply patch #28 (new format of amalgamation files) and bump version number to 2.6.1
Tags
2.6.1
Gerhard Häring
disable unfinished backup functionality
Gerhard Häring
implemented backup functionality
Gerhard Häring
Removed docs about cominbing pysqlite and apsw. This was experimental and I don't want to support it. Added note about using pysqlite in a multithreaded context.
Gerhard Häring
Trying to execute more than one statement with execute() or throwing anything other than string or unicode as the first parameter to execute() now raises a ProgrammingError instead of a Warning. This makes much more sense.
Gerhard Häring
Removed superfluous script.
Gerhard Häring
Changes for newer Sphinx installation.
Gerhard Häring
Fix path to my local installation of the cross building tools.
Gerhard Häring
Bumpbed version number in docs.
Gerhard Häring
Added tag 2.6.0 for changeset 9203d309072e
Gerhard Häring
- We build on Mac OS X 10.6 now - We don't build Python 2.3 and 2.4 binaries any longer
Tags
2.6.0
Gerhard Häring
Merged docs from Python core.
Gerhard Häring
Bump version number to 2.6.0
Gerhard Häring
More merging from Python core. Destroying more Python 2.3 compatibility :-P
Gerhard Häring
- Ported changes from Python core. - I can't build Python 2.3 on the Mac, so Python 2.3 compatibility is dropped now.
Gerhard Häring
Modern unittest idioms imported from Python core.
Gerhard Häring
failUnless => assert Breaks Python Python 2.3 for now.
Gerhard Häring
Fix for Python issue http://bugs.python.org/issue7670
Gerhard Häring
Merge.
Gerhard Häring
Merged patch from Christian Boos to avoid getting errors when installing using Python < 2.5.
Christian Boos
Avoid getting Python 2.5 related syntax errors while building the package with Python 2.3 or 2.4
Gerhard Häring
- Updated version number in docs. - If building against amalgamation (and Windows binaries), include RTree support.
Christian Boos
Fix two other pysqlite.org links (follow-up to 610d40805e)
Gerhard Häring
Removed remaining links to pysqlite.org.
  1. Prev
  2. Next