Commits

portix  committed 53d0918

Check for API-Version in extensions.load

  • Participants
  • Parent commits 3af3868

Comments (0)

Files changed (1)

File scripts/lib/extensions.js

               {
                   plugin._name = name;
 
+                  if (plugin.apiVersion && plugin.apiVersion > version)
+                  {
+                      extensions.error(name, "Required API-Version: \033[1m" + plugin.apiVersion + 
+                                       "\033[0m, API-Version found: \033[1m" + version + "\033[0m");
+                      return;
+                  }
+
                   if (plugin.defaultConfig) 
                       util.mixin(extConfig, plugin.defaultConfig);