Audio utils not working (for me)

Issue #36 new
Mauricio Jabur
created an issue


I'm using toxic libs 0020 on Processing 1.5.1 I have a windows 7 x64 and a windows xp 32 machine.

Trying to run HelloAudioWorld or any other example

On both machines, even after installing oalinst I get the following error: UnsatisfiedLinkError: com.sun.gluegen.runtime.WindowsDynamicLinkerImpl.LoadLibraryW(Ljava/lang/String;)J at at at at at at at Exception in thread "Animation Thread" java.lang.UnsatisfiedLinkError: com.sun.gluegen.runtime.WindowsDynamicLinkerImpl.LoadLibraryW(Ljava/lang/String;)J at com.sun.gluegen.runtime.WindowsDynamicLinkerImpl.LoadLibraryW(Native Method) at com.sun.gluegen.runtime.WindowsDynamicLinkerImpl.openLibrary( at at$DynamicLookup.dynamicLookupFunction( at com.sun.gluegen.runtime.ProcAddressHelper.resetProcAddressTable( at at at Source) at Source) at HelloAudioWorld.setup( at processing.core.PApplet.handleDraw(Unknown Source) at Source) at

the highlighted line on the sketch is audioSys.init();

I tried looking on the internet but got nowhere. I also tried to copy the DLLs generated by oalinst to the library folder, to the java bin folder and it did not fix the problem.

Can you help me please?

Comments (1)

  1. Log in to comment