Commits

Peter Sagerson committed de842da

Version 1.2.0

Comments (0)

Files changed (7)

 
       $ pip install git+https://github.com/rbarrois/python-ldap.git@py3
 
+  Thanks to `Aymeric Augustin <https://myks.org/en/>`_ for making this happen.
+
+
 v1.1.8 - 2014-02-01
 -------------------
 

django_auth_ldap/__init__.py

-version = (1, 1, 8)
+version = (1, 2, 0)
 version_string = '.'.join(map(str, version))

django_auth_ldap/config.py

     from django.utils.encoding import force_str
 except ImportError:  # Django < 1.5
     from django.utils.encoding import smart_str as force_str
-from django.utils import six
 
 
 class _LDAPConfig(object):
 
     def decode(self, value):
         try:
-            if isinstance(value, six.binary_type):
+            if isinstance(value, bytes):
                 value = value.decode(self.encoding)
             elif isinstance(value, list):
                 value = self._decode_list(value)

docs/source/conf.py

 # The short X.Y version.
 version = '1.1'
 # The full version, including alpha/beta/rc tags.
-release = '1.1.8'
+release = '1.2.0'
 
 # The language for content autogenerated by Sphinx. Refer to documentation
 # for a list of supported languages.

docs/source/index.rst

 ================================
 
 This is a Django authentication backend that authenticates against an LDAP
-service. Configuration can be as simple as a single distinguished name
-template, but there are many rich configuration options for working with users,
-groups, and permissions.
+service. Configuration can be as simple as a single distinguished name template,
+but there are many rich configuration options for working with users, groups,
+and permissions.
 
-This version is officially supported on Python >= 2.6 and < 3, Django >= 1.4,
+This version is officially supported on Python >= 2.6 and < 3, Django >= 1.3,
 and python-ldap >= 2.0. It is known to work on earlier versions (especially of
 Django) and backwards-compatibility is not broken needlessly, however users of
-older dependencies are urged to test their deployments carefully and be wary
-of updates.
+older dependencies are urged to test their deployments carefully and be wary of
+updates.
 
 Support for Python >= 3.3 is considered experimental at this time. Since
 python-ldap doesn't support Python 3 yet, you have to install a fork::
 
 setup(
     name="django-auth-ldap",
-    version="1.1.8",
+    version="1.2.0",
     description="Django LDAP authentication backend",
     long_description=open('README').read(),
     url="http://bitbucket.org/psagers/django-auth-ldap/",
 
 
 [tox]
-envlist = py26-django14,
+envlist = py26-django13,
+          py26-django14,
           py27-django15,
           py27-django16,
           py33-django15,