Issues

Issue #18 wontfix

The dependencies should be stated in the setup.py

madjar
created an issue

Installing django-auth-ldap should install django and python-ldap, because it is useless without them.

{{{ install_requires=['django', 'python-ldap'], }}} should be added to the setup.py to install them when installing django-auth-ldap.

Thanks a lot :)

Comments (2)

  1. Peter Sagerson repo owner

    distutils doesn't support install_requires. In my experience, python-ldap is frequently better left to your system's package manager anyway, since it will in turn rely on openldap.

  2. madjar reporter

    Sorry, I meant requires.

    There are many situations where using the system's package is not possible (using a virtualenv because I have no root access, using a custom compiled version of python). In this case, I just feel it should not be needed to write

    django-auth-ldap
    python-ldap
    

    in the requirements.txt.

    But it's mainly for the sake of correctness. Installing a package, then discovering you have to manually install its dependencies just give the feeling the package is not well refined.

  3. Log in to comment