Issue #1 resolved
Richard Jones
created an issue

There's a shader compatibility problem on my MacBook:

(default)l-rjones:lithosphere richard$ python run.py Traceback (most recent call last): File "run.py", line 11, in <module> main() File "/Users/richard/Downloads/lithosphere/lithosphere-0.1.0-py2.6.egg/lithosphere/application.py", line 201, in main File "/Users/richard/Downloads/lithosphere/lithosphere-0.1.0-py2.6.egg/lithosphere/application.py", line 69, in init File "/Users/richard/Downloads/lithosphere/lithosphere-0.1.0-py2.6.egg/lithosphere/viewport.py", line 32, in init File "/Users/richard/Downloads/lithosphere/lithosphere-0.1.0-py2.6.egg/lithosphere/viewport.py", line 51, in load_lighting File "/Users/richard/Downloads/lithosphere/gletools-0.1.0-py2.6.egg/gletools/shader.py", line 55, in open File "/Users/richard/Downloads/lithosphere/gletools-0.1.0-py2.6.egg/gletools/shader.py", line 48, in init gletools.shader.Exception: file: lithosphere/shaders/lighting/spherical_harmonics.frag, failed to compile: ERROR: 0:169: 'pow' : no matching overloaded function found ERROR: 0:169: 'constructor' : not enough data provided for construction

Comments (3)

  1. Log in to comment