1. pygame
  2. pygame
  3. pygame

Issues

Issue #192 wontfix

Freetype rendering too blurred.

Michael Blackwood
created an issue

I am using the msi 1.9.2a0 windows installer for py2.7 from the downloads tab here, dated 2013-08-29.

Below I have a screenshot of 3 screenshot clips. The center is pygame 1.9.1, the left and right are both from 1.9.2a0 using pygame.freetype (same goes for ftfont, of course), antialiased and aliased, respectively. Font sized used is 13. As you can see, the * character is hardly distinguishable as *. Same goes for other intricate characters, like ~. I tried with a handful of fonts, including default windows fonts, and they all suffer from this. (to varying degrees, depending on font.) I found doubling the font size and then using pygame.transform to scale it back down to be significantly clearer than rendering directly to desired size.

I have attached the font used in the screenshot.

Comments (7)

  1. Lenard Lindstrom

    Yes, Pygame 1.9.1 for Python 2.7 renders the attached font more clearly than does Pygame 1.9.2 at size 13. But then the Windows (XP) font viewer does not even recognize system.ttf as "a valid font file."

    Now looking at a Windows font, Arial.ttf, Pygame 1.9.2 (with Python 3.4) renders the font more faithfully that does 1.9.1 (with Python 2.7): 1.9.2 freetype module top (size=13. resolution=96), Wordpad middle, 1.9.1 font module bottom (size=17).

    Arial 13pt

    The 1.9.2 render more closely resembles Windows than does 1.9.1. Here is the same text rendered at size 72 (size 95 with Pygame 1.9.1 font)

    Arial 72pt

    Again Pygame 1.9.2 is a better match to Windows than is Pygame 1.9.1.

    Pygame 1.9.2 uses a newer version of the Freetype 2 than does 1.9.1. This, I suspect, is the reason for differing renders between Pygame versions. Freetype 2 has become more True Type compliant, while system.ttf is not (at least with Windows).

    This is a Pygame documentation issue.

  2. Log in to comment