Max OSX El Capitan "using the deprecated Carbon Component Manager"

Issue #284 new
Travis Travelstead
created an issue

Yesterday I was working on my application and the graphics looked fine. I updated to El Capitan this morning and when going back to work had artifacts and a warning regarding the Carbon Component manager.

Full error. 2015-10-01 15:03:25.649 Python[1301:411338] 15:03:25.649 WARNING: 140: This application, or a library it uses, is using the deprecated Carbon Component Manager for hosting Audio Units. Support for this will be removed in a future release. Also, this makes the host incompatible with version 3 audio units. Please transition to the API's in AudioComponent.h.

It appears to be audio related, but somehow it is also effecting my graphics.

I know that there is always a risk when upgrading right away, and luckily it is more annoying than stopping me from working.

Thanks

Comments (18)

  1. Travis Travelstead reporter

    I uploaded an image of how the graphics look. This is just a portion of my GUI but across the entire button of each blit image I get something like this. This should have a solid dark grey background with a single "DEL" button.

    This is with 1.9.1 and I have not tested it with 1.9.2 yet.

    Voila_ 2015-10-05_08-50-16_AM.png

  2. Chris Bradfield

    Confirming this problem - just updated to 10.11. I use Pygame for teaching, so I have a bunch of simple projects to test with. Most do not run at all - just give the message above and beachball with a blank game window.

    For example, at the following link, I have an example game for students that includes incremental versions of the game as we add each component (shmup-1.py, shmup-2.py, etc). The early versions run fine (simple rectangles). When graphics are added to the sprites, the graphics are not rendered properly, but the game runs. The game stops working at shmup-8.py, where we add text rendering to show the score.

    https://github.com/kidscancode/gamedev/tree/master/shmup

    Hopefully this helps narrow down the problem. Happy to help out with any other troubleshooting.

    UPDATE:

    Turns out I had a bad font cache and needed to run "fc-cache -f", so there's no problem with the text rendering. Graphics are still rendering incorrectly as Travis reports above.

    I suspect this is likely to be an SDL issue and not pygame itself...

  3. Chris Bradfield

    I've been wondering if this isn't perhaps two different issues:

    1) "deprecated Carbon Component Manager" - I've been seeing this warning message on a number of other applications (cmus, for example) and it seems to be just that: a warning. It's not interfering with any of the applications' functions, and doesn't prevent non-graphical (see below) Pygame programs from running normally.

    2) Graphics rendering issue - this is more of a show-stopper bug, and affects any Pygame program that loads external graphics (PNG, JPG, etc).

  4. Travis Travelstead reporter

    I would agree that this is very likely a coincidence. After reading some more and realizing this should only effect audio, that it was a good chance the cause of the issue. Unfortunately it was the only indicator obvious to me. A SDL1.2 graphics rendering issue on 10.11 is most likely the cause.

    For now I can write and test applications, but it looks ugly. I will probably do secondary testing on my Ubuntu virtual machine for now.

    After some more searching I have only found this other mention of the issue. https://www.reddit.com/r/pygame/comments/3njhaw/pygame_issues_in_os_x_1011_el_capitan/

  5. Justin Rowe

    Chris, did you have any luck reverting SDL_image from 1.2.12 to 1.2.10? If so, how did you do it. I can only get pygame to find the SDL_image dylib if I install it using homebrew, and homebrew only has version 1.2.12.

  6. Justin Rowe

    I can confirm that reverting from sdl_image 1.2.12 to version 1.2.10 does fix the graphics glitches. To Install the old version of sdl_image, I changed the name of the existing homebrew formula from /usr/local/Library/Formula/sdl_image.rb to /usr/local/Library/Formula/sdl_image_.rb (just to back it up). I then made a new formula using

    brew create https://www.libsdl.org/projects/SDL_image/release/SDL_image-1.2.10.tar.gz

    Then I changed the contents of the formula that homebrew created to match those of the original formula. I left out the "bottle do" portion, but copied the dependencies, and the install function. Surprisingly this worked without any need for further editing.

  7. Chris Bradfield

    Justin, that's awesome, thanks for the update. I'm afraid I got too busy with other things and didn't have a chance to try it out. There were no other dependencies or conflicts?

  8. telecoda

    The downgrade to 1.2.10 Worked for me after setting SDL_CONFIG env var before running brew install

    export SDL_CONFIG=/usr/local/bin/sdl-config
    brew install sdl_image
    
  9. Bill Hatfield

    I'm having the exact same problem with skewed images. Unfortunately, I'm very much a newbie at this. It seems that reverting the sdl_image from 1.2.12 to 1.2.10 is the solution.

    I would very much appreciate if someone could give me exact command line entries to accomplish this. Justin's comments on 2015-11-19 seem straight forward enough, except for the final comments about changing the formula contents..... No idea how to do that:(

  10. Bill Hatfield

    Well, here's the latest.....

    Fooling around with the image size vs. the screen size in my program, here's what I found:

    If my jpg file was 800 x 600, and my screen size was 700 x 500, the image loaded perfectly, with no skewing. The actual image was of course smaller.

    If my jpg was exactly the same as my screen size, i.e., 700 x 500, the image was always badly skewed.

    If my jpg was 725 x 525 (still slightly larger than my 700 x 500 screen size), the image was partly skewed.

    I've no idea what's going on, but I'm happy to have found a solution.

  11. C.D. MacEachern

    Same issue happening on OS X here with 10.11.3 El Capitan. Downgrading to sdl_image-1.2.10 as others have said here does fix the graphical issues I've come across in several games I've tested. However the sdl_mixer crashes any program trying to load/run .ogg or .mp3 files. I'll file this as a separate bug.

  12. Okakouta

    Has this thread moved? No new posts for a while...

    I'm also using mac OSX and having exclusively the audio issue - is there no solution to this problem?

  13. Log in to comment