Issue #291 new

OS X El Capitan 10.11.3 sound files causing crashes

C.D. MacEachern
created an issue

I've installed pygame via the "brew install pygame" method, and then downgraded the sdl_image library to sdl_image-1.2.10 (1.2.12 is causing graphical glitches currently see issue #284).

Whenever a sound tries to load (tried with both .ogg and .mp3 files, after having installed the dependencies via "brew install" method) python crashes with the following error:

"Python unexpectedly quit while using the libSDL-1.2.0.dylib plugin"

python(64369,0x7fff7bd0a000) malloc: error for object 0x7fe9cc021ca0: pointer being freed was not allocated set a breakpoint in malloc_error_break to debug Abort trap: 6

I've tried downgrading the sdl_mixer as well to 1.2.10 but it would not install for me using the same methods I used to downgrade sdl_image. Not sure what else to do at this point! I cannot play any games that require playing/loading sounds! I've testing removing sounds entirely in the source code and the game ran fine.

Comments (4)

  1. Justin Rowe

    I have noticed the same problem. The only solution that I could find was to use wav files, which is unfortunate because it drastically increased the size of my project.

  2. Justin Rowe

    I should also note that the game was able to play .ogg files when running from source using the libraries installed using homebrew. There is one little trick: when you install sdl mixer you need to use the "with libvorbis" option. Uninstall both libvorbis and the sdl_mixer first, then reinstall using the option. I will try to find a link with the actual commands.

    However, while this will work when running the game from source it will not continue to work if you package the game using py2app. somehow the linking of the libraries gets all screwed up.

    I don't think this is a pygame issue - I think it is an issue with the way that homebrew installs the libraries.

  3. Log in to comment