Separate build and install package requirements for basic, X and OpenGL

Issue #306 new
PanderMusubi
created an issue

The packages that need to be installed for building and for installing pygame need to be organised into three groups:

  • bare minimal for building
  • minimal for building with support for X
  • minimal for building with support for OpenGL (support for X implied)
  • bare minimal for installing
  • minimal for installing with support for X (recommend packages)
  • minimal for installing with support for OpenGL (suggested packages)

This is important as pygame can easily be installed on more minimal systems suchas headless systems, Raspberry Pis without X, Raspberry Pis without OpenGL, etc.

See also: