1. pygame
  2. pygame
  3. pygame
  4. Issues

Issues

Issue #42 resolved

Package 1.9 for Mac requires System Python, even if there.

René Dudfield
created an issue

== Alexandre Quessy, 2010-01-03 16:33:25 -0800

{{{ It is impossible to install pygame on my Mac OS X from the packages provided on the page http://pygame.org/download.shtml

I tried the three packages : * pygame-1.9.1release-py2.6-macosx10.5.zip 10.3MB * pygame-1.9.1release-py2.5-macosx10.5.zip 10.3MB * pygame-1.9.1release-py2.4-macosx10.5.zip 10.3MB

And they all give me the following error : (sorry for the french)

  • Vous ne pouvez pas installer pygame 1.9.1release sur ce volume. pygame requires System Python 2.4 to install.
  • Vous ne pouvez pas installer pygame 1.9.1release sur ce volume. pygame requires System Python 2.5 to install.
  • Vous ne pouvez pas installer pygame 1.9.1release sur ce volume. pygame requires System Python 2.6 to install.

I use Mac OS 10.5.8 on a MacBook Pro with a 2.2 GHz Intel Core 2 Duo CPU, 2 Gb of RAM and 500 Gb of hard drive space. There is a Python that is installed with Mac OS X.

I installed a few MacPorts Python packages though, and it might be the reason :

python24 @2.4.6 (lang) An interpreted, object-oriented programming language python25 @2.5.4 (lang) An interpreted, object-oriented programming language

But when I issue "which python" in a Terminal, it is the System Python that is listed, I think.

buzz:twisted aalex$ python -V Python 2.5.1 buzz:twisted aalex$ which python /usr/bin/python }}}


== Alexandre Quessy, 2010-01-03 19:34:16 -0800

{{{ This is fixed once I have installed http://www.python.org/ftp/python/2.5/python-2.5-macosx.dmg

This should be documented. }}}


Comments (2)

  1. Log in to comment