Issue #24 resolved

some dists with odd versions are missing `index-metadata`

C Anthony Risinger
created an issue

distil-258fbf-32a4bc.py, but i think the issue itself is with distlib:

...only the oldest (0.1.7) works as expected, the others simply produce this "error message":

[any@sh ~]$ python2 ./distil-258fbf-32a4bc.py package --formats=wheel
'index-metadata'

...same problem here:

...it's worth noting that the default_locator does not return any of these missing dists either (if that's obvious/given, forgive me)

also, i was unable to create wheels for these due to some undefined symbol issues (could not look further):

Comments (2)

  1. Vinay Sajip

    The problem with the more recent GitPython versions and pytz is that their version numbers are not PEP-compliant, so the index-metadata part of the package JSON isn't created .IIRC pytz is referred to specifically in the PEP(s).

    In terms of psycopg2 and pycrypto, they require certain header files from the relevant PostgresSQL / various crypto distributions - do you have these installed on the machine where you hit the build errors?

    Update: Some distributions execute code in setup.py which is environment-dependent, and so impossible to capture in a declarative format such as the JSON metadata. To build wheels for these, you have to have pip available (I know you don't like it) to build wheels (using distil pip). Normally distil package should do, but unfortunately there are a lot of distributions which use setup.py to e.g. generate source files, move files around etc. - and for these, distil package may not work, whereas distil pip should, because it actually executes setup.py.

  2. Log in to comment