Commits

Donald Stufft  committed 6c8bf58

Remove the parethensis from the vesion specifier

  • Participants
  • Parent commits d5d1fbc

Comments (0)

Files changed (2)

File core-metadata.rst

 Individual requirements are defined as strings containing a distribution
 name (as found in the ``name`` field). The distribution name
 may be followed by an extras specifier (enclosed in square
-brackets) and by a version specifier or direct reference (within
-parentheses).
+brackets) and by a version specifier or direct reference.
 
 Whitespace is permitted between the distribution name and an opening
 square bracket or parenthesis. Whitespace is also permitted between a
-closing square bracket and an opening parenthesis.
+closing square bracket and the version specifier.
 
 See `Extras (optional dependencies)`_ for details on extras and PEP 440
 for details on version specifiers and direct references.
     "Flask"
     "Django"
     "Pyramid"
-    "SciPy (0.12)"
+    "SciPy ~= 0.12"
     "ComfyChair[warmup]"
-    "ComfyChair[warmup] (> 0.1)"
+    "ComfyChair[warmup] > 0.1"
 
 
 Mapping dependencies to development and distribution activities
 
     "run_requires":
       {
-        "requires": ["SciPy", "PasteDeploy", "zope.interface (>3.5.0)"]
+        "requires": ["SciPy", "PasteDeploy", "zope.interface>3.5.0"]
       },
       {
-        "requires": ["pywin32 (>1.0)"],
+        "requires": ["pywin32 > 1.0"],
         "environment": "sys_platform == 'win32'"
       },
       {
 
     "meta_requires":
       {
-        "requires": ["ComfyUpholstery (== 1.0a2)",
-                     "ComfySeatCushion (== 1.0a2)"]
+        "requires": ["ComfyUpholstery == 1.0a2",
+                     "ComfySeatCushion == 1.0a2"]
       },
       {
-        "requires": ["CupOfTeaAtEleven (== 1.0a2)"],
+        "requires": ["CupOfTeaAtEleven == 1.0a2"],
         "environment": "'linux' in sys_platform"
       }
     ]
         "requires": ["unittest2"]
       },
       {
-        "requires": ["pywin32 (>1.0)"],
+        "requires": ["pywin32 > 1.0"],
         "environment": "sys_platform == 'win32'"
       },
       {
 
     "build_requires":
       {
-        "requires": ["setuptools (>= 0.7)"]
+        "requires": ["setuptools >= 0.7"]
       },
       {
-        "requires": ["pywin32 (>1.0)"],
+        "requires": ["pywin32 > 1.0"],
         "environment": "sys_platform == 'win32'"
       },
       {
 
     "dev_requires":
       {
-        "requires": ["hgtools", "sphinx (>= 1.0)"]
+        "requires": ["hgtools", "sphinx >= 1.0"]
       },
       {
-        "requires": ["pywin32 (>1.0)"],
+        "requires": ["pywin32 > 1.0"],
         "environment": "sys_platform == 'win32'"
       }
     ]
     "obsoleted_by": "AcceptableName"
 
     "name": "distribute",
-    "obsoleted_by": "setuptools (>= 0.7)"
+    "obsoleted_by": "setuptools >= 0.7"
 
 
 Metadata Extensions
     "name": "ComfyChair",
     "run_requires": [
       {
-        "requires": ["pywin32 (>1.0)"],
+        "requires": ["pywin32 > 1.0"],
         "environment": "sys.platform == 'win32'"
       }
     ]
     "build_requires": [
       {
-        "requires": ["pywin32 (>1.0)"],
+        "requires": ["pywin32 > 1.0"],
         "environment": "sys.platform == 'win32'"
       }
     ]
 Alternative dependency specification example::
 
    ["Pillow", "PIL"]
-   ["mysql", "psycopg2 (>= 4)", "sqlite3"]
+   ["mysql", "psycopg2 >= 4", "sqlite3"]
 
 However, neither of the given examples is particularly compelling,
 since Pillow/PIL style forks aren't common, and the database driver use

File versioning.rst

 
 This change is designed to ensure that an integrator provided version like
 ``pip 1.5~1`` or ``pip~1.5-1.git.abc123de`` will still satisfy a version
-specifier like ``pip (>= 1.5)``.
+specifier like ``pip>=1.5``.
 
 The tilde is chosen primarily for readability of local version identifiers. It
 was chosen instead of the hyphen to prevent ``pkg_resources.parse_version``