Issue #128 wontfix

Wheels cannot be uploaded for versions that start with a letter

Jaime Marquínez Ferrándiz
created an issue

I was trying to upload a wheel for my package: youtube_dl_server ( and I was always getting HTTP Error 400: Binary wheel for an unsupported platform when running python bdist_wheel upload.

I think that the problem is whith the wheel_file_re in, if I get the match object (with the filename youtube_dl_server-alpha.5-py2.py3-none-any.whl) the plat group is 'none-any' (it should be 'any'), that's the reason why it raises the error later. Changing the version to something like 0.1 allows to upload the wheel.

Maybe I should just change the version scheme, but I thought you would want to know the problem. If you need more info, please ask.

Comments (2)

  1. Log in to comment