Commits

Jason R. Coombs committed 025ccf7

Drop support for Python 2.5 and Python 2.4. Fixes #41.

  • Participants
  • Parent commits 09eaf81

Comments (0)

Files changed (8)

 CHANGES
 =======
 
+---
+2.0
+---
+
+* Issue #41: Dropped support for Python 2.4 and Python 2.5. Clients requiring
+  setuptools for those versions of Python should use setuptools 1.x.
+
 -----
 1.4.1
 -----

File docs/easy_install.txt

 for download links and basic installation instructions for each of the
 supported platforms.
 
-You will need at least Python 2.4.  An ``easy_install`` script will be
+You will need at least Python 2.6.  An ``easy_install`` script will be
 installed in the normal location for Python scripts on your platform.
 
 Note that the instructions on the setuptools PyPI page assume that you are

File docs/pkg_resources.txt

 
 py_version
     The major/minor Python version the distribution supports, as a string.
-    For example, "2.3" or "2.4".  The default is the current version of Python.
+    For example, "2.7" or "3.4".  The default is the current version of Python.
 
 platform
     A string representing the platform the distribution is intended for, or

File docs/setuptools.txt

 ==================================================
 
 ``Setuptools`` is a collection of enhancements to the Python ``distutils``
-(for Python 2.3.5 and up on most platforms; 64-bit platforms require a minimum
-of Python 2.4) that allow you to more easily build and distribute Python
-packages, especially ones that have dependencies on other packages.
+(for Python 2.6 and up) that allow developers to more easily build and
+distribute Python packages, especially ones that have dependencies on other
+packages.
 
 Packages built and distributed using ``setuptools`` look to the user like
 ordinary Python packages based on the ``distutils``.  Your users don't need to
 except ImportError:
     USER_SITE = None
 
-DEFAULT_VERSION = "1.4.2"
+DEFAULT_VERSION = "2.0"
 DEFAULT_URL = "https://pypi.python.org/packages/source/s/setuptools/"
 
 def _python_cmd(*args):

File pkg_resources.py

         `platform` is an optional string specifying the name of the platform
         that platform-specific distributions must be compatible with.  If
         unspecified, it defaults to the current platform.  `python` is an
-        optional string naming the desired version of Python (e.g. ``'2.4'``);
+        optional string naming the desired version of Python (e.g. ``'3.3'``);
         it defaults to the current version.
 
         You may explicitly set `platform` (and/or `python`) to ``None`` if you
         License :: OSI Approved :: Python Software Foundation License
         License :: OSI Approved :: Zope Public License
         Operating System :: OS Independent
-        Programming Language :: Python :: 2.4
-        Programming Language :: Python :: 2.5
         Programming Language :: Python :: 2.6
         Programming Language :: Python :: 2.7
         Programming Language :: Python :: 3
         """).strip().splitlines(),
     extras_require = {
         "ssl:sys_platform=='win32'": "wincertstore==0.1",
-        "ssl:sys_platform=='win32' and python_version=='2.4'": "ctypes==1.0.2",
-        "ssl:python_version in '2.4, 2.5'":"ssl==1.16",
         "certs": "certifi==0.0.8",
     },
     dependency_links = [
         'https://pypi.python.org/packages/source/c/certifi/certifi-0.0.8.tar.gz#md5=dc5f5e7f0b5fc08d27654b17daa6ecec',
-        'https://pypi.python.org/packages/source/s/ssl/ssl-1.16.tar.gz#md5=fb12d335d56f3c8c7c1fefc1c06c4bfb',
         'https://pypi.python.org/packages/source/w/wincertstore/wincertstore-0.1.zip#md5=2f9accbebe8f7b4c06ac7aa83879b81c',
-        'https://bitbucket.org/pypa/setuptools/downloads/ctypes-1.0.2.win32-py2.4.exe#md5=9092a0ad5a3d79fa2d980f1ddc5e9dbc',
-        'https://bitbucket.org/pypa/setuptools/downloads/ssl-1.16-py2.4-win32.egg#md5=3cfa2c526dc66e318e8520b6f1aadce5',
-        'https://bitbucket.org/pypa/setuptools/downloads/ssl-1.16-py2.5-win32.egg#md5=85ad1cda806d639743121c0bbcb5f39b',
     ],
     scripts = [],
     # tests_require = "setuptools[ssl]",

File setuptools/version.py

-__version__ = '1.4.2'
+__version__ = '2.0'