Issue #139 resolved

AttributeError: 're_finder' object has no attribute 'find'

Jose Diaz-Gonzalez
created an issue

The method find does not exist in re_finder. I find this bug whenever installing a package from github.


[] out: Downloading/unpacking pycurl from git+git:// (from -r /apps/production/api/current/requirements.txt (line 5))
[] out:   Cloning git:// to /mnt/apps/production/api/virtualenvs/api/build/pycurl
[] out:   Running (path:/mnt/apps/production/api/virtualenvs/api/build/pycurl/ egg_info for package pycurl
[] out:     Using curl-config (libcurl 7.22.0)
[] out:
[] out:     Traceback (most recent call last):
[] out:       File "<string>", line 17, in <module>
[] out:       File "/mnt/apps/production/api/virtualenvs/api/build/pycurl/", line 225, in <module>
[] out:         apply(setup, (), setup_args)
[] out:       File "/usr/lib/python2.7/distutils/", line 152, in setup
[] out:         dist.run_commands()
[] out:       File "/usr/lib/python2.7/distutils/", line 953, in run_commands
[] out:         self.run_command(cmd)
[] out:       File "/usr/lib/python2.7/distutils/", line 972, in run_command
[] out:
[] out:       File "<string>", line 15, in replacement_run
[] out:       File "/apps/production/api/virtualenvs/api/local/lib/python2.7/site-packages/setuptools/command/", line 186, in find_sources
[] out:
[] out:       File "/apps/production/api/virtualenvs/api/local/lib/python2.7/site-packages/setuptools/command/", line 246, in run
[] out:         self.add_defaults()
[] out:       File "/apps/production/api/virtualenvs/api/local/lib/python2.7/site-packages/setuptools/command/", line 285, in add_defaults
[] out:         rcfiles = list(walk_revctrl())
[] out:       File "/apps/production/api/virtualenvs/api/local/lib/python2.7/site-packages/setuptools/command/", line 18, in walk_revctrl
[] out:         for item in ep.load()(dirname):
[] out:       File "/apps/production/api/virtualenvs/api/local/lib/python2.7/site-packages/setuptools/command/", line 58, in _default_revctrl
[] out:         for item in finder(dirname):
[] out:       File "/apps/production/api/virtualenvs/api/local/lib/python2.7/site-packages/setuptools/command/", line 51, in __call__
[] out:         for item in self.find(path):
[] out:     AttributeError: 're_finder' object has no attribute 'find'

Comments (8)

  1. Piotr Dobrogost

    We have a script, which checks out c source code from CVS, drives compilation, makes a list of compiled libs and runs normal setup with this list passed as data_files argument. This is kind of hackish way to get our binary libs installed into virtualenv. Anyway, it was working fine when it was created a few months ago but today when I tried to run it with the newest setuptools (2.1) it broke with the error described by OP in this issue. I tried a few versions of setuptools and from what I can see the first version which broke our script was 1.2 (1.1.7 is ok) but with different error:

      File "/home/users/pdobrogost/venv/lib/python2.7/site-packages/setuptools/command/", line 38, in _finder
        if postproc:
    NameError: global name 'postproc' is not defined
  2. Log in to comment