Commits

Victor Garcia  committed c2210f4

Make the fieldsets in entry page a table.

  • Participants
  • Parent commits 5a4dca5

Comments (0)

Files changed (75)

 when running Bazaar's testsuite with either PyPy 1.4.1 or a nightly build.
 
 ----
-\\ URL: http://bazaar.canonical.com/en/
-\\ Category: Applications
-\\ Compatible: {{incompatible.gif | Incompatible}}
-==== Soft Dependencies
- * [[http://cython.org/ | Cython]] {{incompatible.gif | Incompatible}}
- * [[http://www.lag.net/paramiko/ | paramiko]] {{unknown.gif | Compatibility Unknown}}
- * [[http://www.dlitz.net/software/pycrypto/ | Python Cryptography Toolkit (PyCrypto)]] {{incompatible.gif | Incompatible}}
- * [[http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/ | Pyrex]] {{incompatible.gif | Incompatible}}
+| URL:| http://bazaar.canonical.com/en/|
+| Category: | Applications|
+| Compatible: | {{incompatible.gif | Incompatible}}|
+
+|= Soft Dependencies |
+| [[http://cython.org/ | Cython]] {{incompatible.gif | Incompatible}} |
+| [[http://www.lag.net/paramiko/ | paramiko]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://www.dlitz.net/software/pycrypto/ | Python Cryptography Toolkit (PyCrypto)]] {{incompatible.gif | Incompatible}} |
+| [[http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/ | Pyrex]] {{incompatible.gif | Incompatible}} |
 CPython 2.7.
 
 ----
-\\ URL: http://beaker.groovie.org/
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[http://tahoe-lafs.org/trac/pycryptopp | pycryptopp]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://beaker.groovie.org/|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[http://tahoe-lafs.org/trac/pycryptopp | pycryptopp]] {{unknown.gif | Compatibility Unknown}} |

File beautiful_soup.wiki

 two that depend on cjkcodecs.
 
 ----
-\\ URL: http://www.crummy.com/software/BeautifulSoup/
-\\ Category: Parsers and parser generators
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://www.crummy.com/software/BeautifulSoup/|
+| Category: | Parsers and parser generators|
+| Compatible: | {{compatible.gif | Compatible}}|

File biopython.wiki

 others. Biopython's C extensions fail to build with PyPy.
 
 ----
-\\ URL: http://biopython.org/
-\\ Category: Scientific libraries
-\\ Compatible: {{incompatible.gif | Incompatible}}
-==== Soft Dependencies
- * [[mysql-python | MySQL-Python (MySQLdb)]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[numpy | Numpy]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}
- * [[psycopg2 | Psycopg2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[http://code.google.com/p/pysqlite/ | pysqlite (sqlite3)]] {{compatible.gif | Compatible}}
+| URL:| http://biopython.org/|
+| Category: | Scientific libraries|
+| Compatible: | {{incompatible.gif | Incompatible}}|
+
+|= Soft Dependencies |
+| [[mysql-python | MySQL-Python (MySQLdb)]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[numpy | Numpy]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}|
+| [[psycopg2 | Psycopg2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[http://code.google.com/p/pysqlite/ | pysqlite (sqlite3)]] {{compatible.gif | Compatible}} |
 Bottle is compatible with PyPy, all of its tests pass with a nightly build.
 
 ----
-\\ URL: http://bottle.paws.de/
-\\ Category: Frameworks and application servers
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[https://github.com/jonashaag/bjoern | bjoern]] {{unknown.gif | Compatibility Unknown}}
- * [[http://www.cheetahtemplate.org/ | Cheetah]] {{unknown.gif | Compatibility Unknown}}
- * [[http://www.cherrypy.org/ | CherryPy]] {{unknown.gif | Compatibility Unknown}}
- * [[http://www.fapws.org/ | FAPWS]] {{unknown.gif | Compatibility Unknown}}
- * [[http://code.google.com/appengine/ | GAE (Google App Engine)]] {{unknown.gif | Compatibility Unknown}}
- * [[jinja2 | Jinja2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[mako | Mako]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[paste | Paste]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
+| URL:| http://bottle.paws.de/|
+| Category: | Frameworks and application servers|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[https://github.com/jonashaag/bjoern | bjoern]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://www.cheetahtemplate.org/ | Cheetah]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://www.cherrypy.org/ | CherryPy]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://www.fapws.org/ | FAPWS]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://code.google.com/appengine/ | GAE (Google App Engine)]] {{unknown.gif | Compatibility Unknown}} |
+| [[jinja2 | Jinja2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[mako | Mako]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[paste | Paste]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|

File chameleon.wiki

 with PyPy.
 
 ----
-\\ URL: http://chameleon.repoze.org/
-\\ Category: Templating Engines
-\\ Compatible: {{incompatible.gif | Incompatible}}
+| URL:| http://chameleon.repoze.org/|
+| Category: | Templating Engines|
+| Compatible: | {{incompatible.gif | Incompatible}}|
 newer.
 
 ----
-\\ URL: http://code.google.com/p/cogen/
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://code.google.com/p/cogen/|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|
 
 ENTRYPAGETPL = r'''{% macro dependency(dep) -%}
 {%- if dep.hasinfo %}
- * [[{{ dep.slug }} | {{ dep.name }}]] {{ COMPAT[dep.compatible] }} {{ INFO }}
+| [[{{ dep.slug }} | {{ dep.name }}]] {{ COMPAT[dep.compatible] }} {{ INFO }}|
 {%- else %}
- * [[{{ dep.url }} | {{ dep.name }}]] {{ COMPAT[dep.compatible] }}
+| [[{{ dep.url }} | {{ dep.name }}]] {{ COMPAT[dep.compatible] }} |
 {%- endif -%}
 {%- endmacro -%}
 = {{ entry.name }}
 
 {{ entry.information }}
 ----
-\\ URL: {{ entry.url }}
-\\ Category: {{ entry.category[6:] }}
-\\ Compatible: {{ COMPAT[entry.compatible] }}
-{% if entry.harddepends -%}
-==== Hard Dependencies
+| URL:| {{ entry.url }}|
+| Category: | {{ entry.category[6:] }}|
+| Compatible: | {{ COMPAT[entry.compatible] }}|
+{% if entry.harddepends %}
+|= Hard Dependencies|
 {%- for dep in entry.harddepends -%}
 {{ dependency(ENTRIES[dep]) }}
 {%- endfor %}
 {% endif -%}
-{% if entry.softdepends -%}
-==== Soft Dependencies
+{% if entry.softdepends %}
+|= Soft Dependencies |
 {%- for dep in entry.softdepends -%}
 {{ dependency(ENTRIES[dep]) }}
 {%- endfor %}

File cx_freeze.wiki

 cx_Freeze is incompatible with PyPy, failing to build against it.
 
 ----
-\\ URL: http://cx-freeze.sourceforge.net/
-\\ Category: Distribution, environment and install tools
-\\ Compatible: {{incompatible.gif | Incompatible}}
+| URL:| http://cx-freeze.sourceforge.net/|
+| Category: | Distribution, environment and install tools|
+| Compatible: | {{incompatible.gif | Incompatible}}|

File cx_oracle.wiki

 include in PyPy.
 
 ----
-\\ URL: http://cx-oracle.sourceforge.net/
-\\ Category: DB adaptors
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://cx-oracle.sourceforge.net/|
+| Category: | DB adaptors|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
 [[Home#!db-adaptors | Psycopg2, PyMySQL, sqlite and MySQLdb]] are supported.
 
 ----
-\\ URL: http://www.djangoproject.com/
-\\ Category: Frameworks and application servers
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[cx_oracle | cx_Oracle]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[http://code.google.com/p/modwsgi/ | modwsgi]] {{unknown.gif | Compatibility Unknown}}
- * [[mysql-python | MySQL-Python (MySQLdb)]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[psycopg2 | Psycopg2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[http://code.google.com/p/pysqlite/ | pysqlite (sqlite3)]] {{compatible.gif | Compatible}}
+| URL:| http://www.djangoproject.com/|
+| Category: | Frameworks and application servers|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[cx_oracle | cx_Oracle]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[http://code.google.com/p/modwsgi/ | modwsgi]] {{unknown.gif | Compatibility Unknown}} |
+| [[mysql-python | MySQL-Python (MySQLdb)]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[psycopg2 | Psycopg2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[http://code.google.com/p/pysqlite/ | pysqlite (sqlite3)]] {{compatible.gif | Compatible}} |

File docutils.wiki

 1.4.1.
 
 ----
-\\ URL: http://docutils.sourceforge.net/
-\\ Category: Document generation
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://docutils.sourceforge.net/|
+| Category: | Document generation|
+| Compatible: | {{compatible.gif | Compatible}}|
 and producing identical renderings for its own documents.
 
 ----
-\\ URL: http://www.nongnu.org/elyxer/
-\\ Category: Document generation
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://www.nongnu.org/elyxer/|
+| Category: | Document generation|
+| Compatible: | {{compatible.gif | Compatible}}|

File feedparser.wiki

 }}}
 
 ----
-\\ URL: http://feedparser.org/
-\\ Category: Parsers and parser generators
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://feedparser.org/|
+| Category: | Parsers and parser generators|
+| Compatible: | {{compatible.gif | Compatible}}|
 Flask is compatible with PyPy, running without any kind of issues.
 
 ----
-\\ URL: http://flask.pocoo.org/
-\\ Category: Frameworks and application servers
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[jinja2 | Jinja2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[werkzeug | Werkzeug]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
-==== Soft Dependencies
- * [[http://code.google.com/p/modwsgi/ | modwsgi]] {{unknown.gif | Compatibility Unknown}}
- * [[http://code.google.com/p/pysqlite/ | pysqlite (sqlite3)]] {{compatible.gif | Compatible}}
- * [[sqlalchemy | SQLAlchemy]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
+| URL:| http://flask.pocoo.org/|
+| Category: | Frameworks and application servers|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[jinja2 | Jinja2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[werkzeug | Werkzeug]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+
+|= Soft Dependencies |
+| [[http://code.google.com/p/modwsgi/ | modwsgi]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://code.google.com/p/pysqlite/ | pysqlite (sqlite3)]] {{compatible.gif | Compatible}} |
+| [[sqlalchemy | SQLAlchemy]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|

File flatland.wiki

 validation.test_signals.test_validator_validated).
 
 ----
-\\ URL: http://discorporate.us/projects/flatland/
-\\ Category: Parsers and parser generators
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[genshi | Genshi]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}
+| URL:| http://discorporate.us/projects/flatland/|
+| Category: | Parsers and parser generators|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[genshi | Genshi]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}|

File flexmock.wiki

 with a nightly build.
 
 ----
-\\ URL: https://github.com/has207/flexmock
-\\ Category: Testing/QA
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| https://github.com/has207/flexmock|
+| Category: | Testing/QA|
+| Compatible: | {{compatible.gif | Compatible}}|
 out of 828).
 
 ----
-\\ URL: http://genshi.edgewall.org/
-\\ Category: Templating Engines
-\\ Compatible: {{incompatible.gif | Incompatible}}
-==== Soft Dependencies
- * [[http://babel.edgewall.org/ | Babel]] {{unknown.gif | Compatibility Unknown}}
- * [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://genshi.edgewall.org/|
+| Category: | Templating Engines|
+| Compatible: | {{incompatible.gif | Incompatible}}|
+
+|= Soft Dependencies |
+| [[http://babel.edgewall.org/ | Babel]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}} |
 gmpy fails to build with PyPy.
 
 ----
-\\ URL: http://code.google.com/p/gmpy/
-\\ Category: Scientific libraries
-\\ Compatible: {{incompatible.gif | Incompatible}}
-==== Hard Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://code.google.com/p/gmpy/|
+| Category: | Scientific libraries|
+| Compatible: | {{incompatible.gif | Incompatible}}|
+
+|= Hard Dependencies|
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |

File gunicorn.wiki

 newer.
 
 ----
-\\ URL: http://gunicorn.org/
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://gunicorn.org/|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|

File html5lib.wiki

 [[http://speed.pypy.org/timeline/?ben=html5lib|known to work]] with PyPy.
 
 ----
-\\ URL: http://code.google.com/p/html5lib/
-\\ Category: Parsers and parser generators
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[lxml | lxml]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}
+| URL:| http://code.google.com/p/html5lib/|
+| Category: | Parsers and parser generators|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[lxml | lxml]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}|

File httplib2.wiki

 Httplib2 is compatible with PyPy, all of its unittests pass.
 
 ----
-\\ URL: http://code.google.com/p/httplib2/
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://code.google.com/p/httplib2/|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|

File ipaddr-py.wiki

 ipaddr-py is compatible with PyPy, all of its unittests pass.
 
 ----
-\\ URL: http://code.google.com/p/ipaddr-py/
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://code.google.com/p/ipaddr-py/|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|
 in its testsuite pass with PyPy 1.4.1.
 
 ----
-\\ URL: http://jinja.pocoo.org/
-\\ Category: Templating Engines
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[http://babel.edgewall.org/ | Babel]] {{unknown.gif | Compatibility Unknown}}
- * [[markupsafe | MarkupSafe]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://jinja.pocoo.org/|
+| Category: | Templating Engines|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[http://babel.edgewall.org/ | Babel]] {{unknown.gif | Compatibility Unknown}} |
+| [[markupsafe | MarkupSafe]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}} |

File jsonlib.wiki

 However, its C-extension doesn't work (despite building fine) with PyPy.
 
 ----
-\\ URL: http://pypi.python.org/pypi/jsonlib
-\\ Category: Parsers and parser generators
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://pypi.python.org/pypi/jsonlib|
+| Category: | Parsers and parser generators|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
 compatible with PyPy yet.
 
 ----
-\\ URL: http://codespeak.net/lxml/
-\\ Category: Parsers and parser generators
-\\ Compatible: {{incompatible.gif | Incompatible}}
-==== Hard Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
- * [[http://cython.org/ | Cython]] {{incompatible.gif | Incompatible}}
+| URL:| http://codespeak.net/lxml/|
+| Category: | Parsers and parser generators|
+| Compatible: | {{incompatible.gif | Incompatible}}|
+
+|= Hard Dependencies|
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://cython.org/ | Cython]] {{incompatible.gif | Incompatible}} |
 with PyPy. It runs faster than on CPython.
 
 ----
-\\ URL: http://www.makotemplates.org/
-\\ Category: Templating Engines
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[markupsafe | MarkupSafe]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
-==== Soft Dependencies
- * [[http://babel.edgewall.org/ | Babel]] {{unknown.gif | Compatibility Unknown}}
- * [[beaker | Beaker]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[pygments | Pygments]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
+| URL:| http://www.makotemplates.org/|
+| Category: | Templating Engines|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[markupsafe | MarkupSafe]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+
+|= Soft Dependencies |
+| [[http://babel.edgewall.org/ | Babel]] {{unknown.gif | Compatibility Unknown}} |
+| [[beaker | Beaker]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[pygments | Pygments]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|

File markupsafe.wiki

 nightly.
 
 ----
-\\ URL: http://www.pocoo.org/projects/markupsafe/
-\\ Category: Parsers and parser generators
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://www.pocoo.org/projects/markupsafe/|
+| Category: | Parsers and parser generators|
+| Compatible: | {{compatible.gif | Compatible}}|

File mechanize.wiki

 540 tests.
 
 ----
-\\ URL: http://wwwsearch.sourceforge.net/mechanize/
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://wwwsearch.sourceforge.net/mechanize/|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|

File mercurial.wiki

 has since been proposed. Status unclear.
 
 ----
-\\ URL: http://mercurial.selenic.com/
-\\ Category: Applications
-\\ Compatible: {{unknown.gif | Compatibility Unknown}}
-==== Soft Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://mercurial.selenic.com/|
+| Category: | Applications|
+| Compatible: | {{unknown.gif | Compatibility Unknown}}|
+
+|= Soft Dependencies |
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
 CPython 2.7.
 
 ----
-\\ URL: http://www.voidspace.org.uk/python/mock/
-\\ Category: Testing/QA
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://www.voidspace.org.uk/python/mock/|
+| Category: | Testing/QA|
+| Compatible: | {{compatible.gif | Compatible}}|
 CPython fail with PyPy.
 
 ----
-\\ URL: http://code.google.com/p/mpmath/
-\\ Category: Scientific libraries
-\\ Compatible: {{unknown.gif | Compatibility Unknown}}
-==== Soft Dependencies
- * [[gmpy | gmpy]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}
+| URL:| http://code.google.com/p/mpmath/|
+| Category: | Scientific libraries|
+| Compatible: | {{unknown.gif | Compatibility Unknown}}|
+
+|= Soft Dependencies |
+| [[gmpy | gmpy]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}|

File mysql-python.wiki

 }}}
 
 ----
-\\ URL: http://mysql-python.sourceforge.net/
-\\ Category: DB adaptors
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://mysql-python.sourceforge.net/|
+| Category: | DB adaptors|
+| Compatible: | {{compatible.gif | Compatible}}|

File netaddr.wiki

 fails.
 
 ----
-\\ URL: http://github.com/drkjam/netaddr
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://github.com/drkjam/netaddr|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|

File networkx.wiki

 instead, 20 out of 888 tests in the NetworkX test suite fail.
 
 ----
-\\ URL: http://networkx.lanl.gov/
-\\ Category: Scientific libraries
-\\ Compatible: {{incompatible.gif | Incompatible}}
-==== Soft Dependencies
- * [[http://matplotlib.sourceforge.net/ | matplotlib]] {{incompatible.gif | Incompatible}}
- * [[numpy | Numpy]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}
- * [[pydot | pydot]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[http://networkx.lanl.gov/pygraphviz/ | PyGraphviz]] {{unknown.gif | Compatibility Unknown}}
- * [[pyparsing | Pyparsing]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[pyyaml | PyYAML]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[http://www.scipy.org/ | SciPy]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://networkx.lanl.gov/|
+| Category: | Scientific libraries|
+| Compatible: | {{incompatible.gif | Incompatible}}|
+
+|= Soft Dependencies |
+| [[http://matplotlib.sourceforge.net/ | matplotlib]] {{incompatible.gif | Incompatible}} |
+| [[numpy | Numpy]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}|
+| [[pydot | pydot]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[http://networkx.lanl.gov/pygraphviz/ | PyGraphviz]] {{unknown.gif | Compatibility Unknown}} |
+| [[pyparsing | Pyparsing]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[pyyaml | PyYAML]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[http://www.scipy.org/ | SciPy]] {{unknown.gif | Compatibility Unknown}} |
 nightly build of PyPy.
 
 ----
-\\ URL: http://code.google.com/p/python-nose/
-\\ Category: Testing/QA
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://code.google.com/p/python-nose/|
+| Category: | Testing/QA|
+| Compatible: | {{compatible.gif | Compatible}}|
 [[https://bitbucket.org/pypy/pypy/src/micronumpy | micronumpy branch]].
 
 ----
-\\ URL: http://numpy.scipy.org/
-\\ Category: Scientific libraries
-\\ Compatible: {{incompatible.gif | Incompatible}}
-==== Hard Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
- * [[http://www.swig.org/ | SWIG]] {{incompatible.gif | Incompatible}}
+| URL:| http://numpy.scipy.org/|
+| Category: | Scientific libraries|
+| Compatible: | {{incompatible.gif | Incompatible}}|
+
+|= Hard Dependencies|
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://www.swig.org/ | SWIG]] {{incompatible.gif | Incompatible}} |
 nightly as do with Python 2.7
 
 ----
-\\ URL: http://pythonpaste.org/
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[http://www.saddi.com/software/flup/ | flup]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://pythonpaste.org/|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[http://www.saddi.com/software/flup/ | flup]] {{unknown.gif | Compatibility Unknown}} |
 CPython 2.7.
 
 ----
-\\ URL: http://pybrary.net/pg8000/
-\\ Category: DB adaptors
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[pytz | pytz]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
+| URL:| http://pybrary.net/pg8000/|
+| Category: | DB adaptors|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[pytz | pytz]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
 cause is unclear.
 
 ----
-\\ URL: http://www.dabeaz.com/ply/
-\\ Category: Parsers and parser generators
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://www.dabeaz.com/ply/|
+| Category: | Parsers and parser generators|
+| Compatible: | {{compatible.gif | Compatible}}|

File psycopg2.wiki

 PyPy yourself.
 
 ----
-\\ URL: http://initd.org/psycopg/
-\\ Category: DB adaptors
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://initd.org/psycopg/|
+| Category: | DB adaptors|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
 [[pytest]] and part of its source checkout.
 
 ----
-\\ URL: http://pylib.org/
-\\ Category: Popular/interesting/miscellaneous libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://pylib.org/|
+| Category: | Popular/interesting/miscellaneous libraries|
+| Compatible: | {{compatible.gif | Compatible}}|

File pyccuracy.wiki

 CPython 2.7.
 
 ----
-\\ URL: https://github.com/heynemann/pyccuracy/wiki/
-\\ Category: Testing/QA
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[selenium | Selenium Python Client Driver]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
+| URL:| https://github.com/heynemann/pyccuracy/wiki/|
+| Category: | Testing/QA|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[selenium | Selenium Python Client Driver]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
 pydot is compatible with PyPy, all of its tests pass with a nightly build.
 
 ----
-\\ URL: http://code.google.com/p/pydot/
-\\ Category: Parsers and parser generators
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://code.google.com/p/pydot/|
+| Category: | Parsers and parser generators|
+| Compatible: | {{compatible.gif | Compatible}}|

File pyftpdlib.wiki

 fail or error and tests in ThrottleBandwidth hang.
 
 ----
-\\ URL: http://code.google.com/p/pyftpdlib/
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://code.google.com/p/pyftpdlib/|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|
 passed.
 
 ----
-\\ URL: http://www.pyglet.org/
-\\ Category: Game/Multimedia libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://www.pyglet.org/|
+| Category: | Game/Multimedia libraries|
+| Compatible: | {{compatible.gif | Compatible}}|

File pygments.wiki

 1.4.1.
 
 ----
-\\ URL: http://pygments.org/
-\\ Category: Document generation
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://pygments.org/|
+| Category: | Document generation|
+| Compatible: | {{compatible.gif | Compatible}}|
  - [[umit | UMIT]]
 
 ----
-\\ URL: http://www.pygtk.org/
-\\ Category: GUI library bindings
-\\ Compatible: {{incompatible.gif | Incompatible}}
-==== Hard Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
-==== Soft Dependencies
- * [[numpy | Numpy]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}
+| URL:| http://www.pygtk.org/|
+| Category: | GUI library bindings|
+| Compatible: | {{incompatible.gif | Incompatible}}|
+
+|= Hard Dependencies|
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
+
+|= Soft Dependencies |
+| [[numpy | Numpy]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}|

File pymysql.wiki

 PyPy.
 
 ----
-\\ URL: http://code.google.com/p/pymysql/
-\\ Category: DB adaptors
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://code.google.com/p/pymysql/|
+| Category: | DB adaptors|
+| Compatible: | {{compatible.gif | Compatible}}|

File pyparsing.wiki

 CPython 2.7.
 
 ----
-\\ URL: http://pyparsing.wikispaces.com/
-\\ Category: Parsers and parser generators
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://pyparsing.wikispaces.com/|
+| Category: | Parsers and parser generators|
+| Compatible: | {{compatible.gif | Compatible}}|

File pyramid.wiki

 templates are supported.
 
 ----
-\\ URL: http://pylonsproject.org/projects/pyramid/about
-\\ Category: Frameworks and application servers
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[chameleon | Chameleon]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}
- * [[paste | Paste]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[http://pythonpaste.org/deploy/ | PasteDeploy]] {{unknown.gif | Compatibility Unknown}}
- * [[http://pythonpaste.org/script/ | PasteScript]] {{unknown.gif | Compatibility Unknown}}
- * [[webob | WebOb]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[http://www.zope.org/ | Zope]] {{incompatible.gif | Incompatible}}
+| URL:| http://pylonsproject.org/projects/pyramid/about|
+| Category: | Frameworks and application servers|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[chameleon | Chameleon]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}|
+| [[paste | Paste]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[http://pythonpaste.org/deploy/ | PasteDeploy]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://pythonpaste.org/script/ | PasteScript]] {{unknown.gif | Compatibility Unknown}} |
+| [[webob | WebOb]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[http://www.zope.org/ | Zope]] {{incompatible.gif | Incompatible}} |
 PyPy nightly.
 
 ----
-\\ URL: http://www.xs4all.nl/~irmen/pyro3/
-\\ Category: Parallel/remote execution and task queues
-\\ Compatible: {{incompatible.gif | Incompatible}}
+| URL:| http://www.xs4all.nl/~irmen/pyro3/|
+| Category: | Parallel/remote execution and task queues|
+| Compatible: | {{incompatible.gif | Incompatible}}|
 part of its source checkout.
 
 ----
-\\ URL: http://pytest.org
-\\ Category: Testing/QA
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[py | py]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
-==== Soft Dependencies
- * [[http://codespeak.net/execnet/ | execnet]] {{compatible.gif | Compatible}}
+| URL:| http://pytest.org|
+| Category: | Testing/QA|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[py | py]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+
+|= Soft Dependencies |
+| [[http://codespeak.net/execnet/ | execnet]] {{compatible.gif | Compatible}} |

File python-graph.wiki

 on CPython fail with PyPy.
 
 ----
-\\ URL: http://code.google.com/p/python-graph/
-\\ Category: Scientific libraries
-\\ Compatible: {{incompatible.gif | Incompatible}}
-==== Hard Dependencies
- * [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://code.google.com/p/python-graph/|
+| Category: | Scientific libraries|
+| Compatible: | {{incompatible.gif | Incompatible}}|
+
+|= Hard Dependencies|
+| [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}} |

File python_imaging_library.wiki

 isn't supported.
 
 ----
-\\ URL: http://www.pythonware.com/products/pil/
-\\ Category: Game/Multimedia libraries
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
-==== Soft Dependencies
- * [[http://docs.python.org/library/tkinter.html | Tkinter]] {{incompatible.gif | Incompatible}}
+| URL:| http://www.pythonware.com/products/pil/|
+| Category: | Game/Multimedia libraries|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
+
+|= Soft Dependencies |
+| [[http://docs.python.org/library/tkinter.html | Tkinter]] {{incompatible.gif | Incompatible}} |
 1.4.1.
 
 ----
-\\ URL: http://pytz.sourceforge.net/
-\\ Category: Popular/interesting/miscellaneous libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://pytz.sourceforge.net/|
+| Category: | Popular/interesting/miscellaneous libraries|
+| Compatible: | {{compatible.gif | Compatible}}|
 PyYAML works with PyPy, with a fully passing test suite.
 
 ----
-\\ URL: http://pyyaml.org/wiki/PyYAML
-\\ Category: Parsers and parser generators
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
- * [[http://cython.org/ | Cython]] {{incompatible.gif | Incompatible}}
+| URL:| http://pyyaml.org/wiki/PyYAML|
+| Category: | Parsers and parser generators|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://cython.org/ | Cython]] {{incompatible.gif | Incompatible}} |

File reportlab_toolkit.wiki

 }}}
 
 ----
-\\ URL: http://www.reportlab.com/software/opensource/rl-toolkit/
-\\ Category: Document generation
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
- * [[python imaging library | Python Imaging Library (PIL)]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
+| URL:| http://www.reportlab.com/software/opensource/rl-toolkit/|
+| Category: | Document generation|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
+| [[python imaging library | Python Imaging Library (PIL)]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
 CPython 2.7.
 
 ----
-\\ URL: https://launchpad.net/rocket
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| https://launchpad.net/rocket|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|
 recent PyPy versions.
 
 ----
-\\ URL: http://www.scons.org/
-\\ Category: Software construction (make alternatives)
-\\ Compatible: {{incompatible.gif | Incompatible}}
+| URL:| http://www.scons.org/|
+| Category: | Software construction (make alternatives)|
+| Compatible: | {{incompatible.gif | Incompatible}}|

File selenium.wiki

 pass with a PyPy nightly.
 
 ----
-\\ URL: http://code.google.com/p/selenium/
-\\ Category: Testing/QA
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[http://packages.python.org/distribute/ | Distribute]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://code.google.com/p/selenium/|
+| Category: | Testing/QA|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[http://packages.python.org/distribute/ | Distribute]] {{unknown.gif | Compatibility Unknown}} |

File shed_skin.wiki

 C++ extension.
 
 ----
-\\ URL: http://code.google.com/p/shedskin/
-\\ Category: Code/wrapper generators
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://code.google.com/p/shedskin/|
+| Category: | Code/wrapper generators|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
 Sphinx seems to (almost) fully work with PyPy. Only two tests fail.
 
 ----
-\\ URL: http://sphinx.pocoo.org/
-\\ Category: Document generation
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[docutils | Docutils]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[jinja2 | Jinja2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[pygments | Pygments]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
+| URL:| http://sphinx.pocoo.org/|
+| Category: | Document generation|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[docutils | Docutils]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[jinja2 | Jinja2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[pygments | Pygments]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|

File sqlalchemy.wiki

 some corner cases might not be supported
 
 ----
-\\ URL: http://www.sqlalchemy.org/
-\\ Category: ORMs
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}}
- * [[https://launchpad.net/myconnpy | MySQL Connector/Python]] {{unknown.gif | Compatibility Unknown}}
- * [[pg8000 | pg8000]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[psycopg2 | Psycopg2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[http://code.google.com/p/pyodbc/ | pyodbc]] {{unknown.gif | Compatibility Unknown}}
- * [[http://python.projects.postgresql.org/ | py-postgresql]] {{incompatible.gif | Incompatible}}
- * [[http://code.google.com/p/pysqlite/ | pysqlite (sqlite3)]] {{compatible.gif | Compatible}}
+| URL:| http://www.sqlalchemy.org/|
+| Category: | ORMs|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[c-api | C-API]] {{unknown.gif | Compatibility Unknown}} |
+| [[https://launchpad.net/myconnpy | MySQL Connector/Python]] {{unknown.gif | Compatibility Unknown}} |
+| [[pg8000 | pg8000]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[psycopg2 | Psycopg2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[http://code.google.com/p/pyodbc/ | pyodbc]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://python.projects.postgresql.org/ | py-postgresql]] {{incompatible.gif | Incompatible}} |
+| [[http://code.google.com/p/pysqlite/ | pysqlite (sqlite3)]] {{compatible.gif | Compatible}} |
 A large portion of SymPy appears to work correctly with PyPy.
 
 ----
-\\ URL: http://sympy.org/
-\\ Category: Scientific libraries
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[pyglet | pyglet]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[mpmath | mpmath]] {{unknown.gif | Compatibility Unknown}} {{moreinfo.gif | More Information}}
-==== Soft Dependencies
- * [[numpy | Numpy]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}
- * [[http://cython.org/ | Cython]] {{incompatible.gif | Incompatible}}
+| URL:| http://sympy.org/|
+| Category: | Scientific libraries|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[pyglet | pyglet]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[mpmath | mpmath]] {{unknown.gif | Compatibility Unknown}} {{moreinfo.gif | More Information}}|
+
+|= Soft Dependencies |
+| [[numpy | Numpy]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}|
+| [[http://cython.org/ | Cython]] {{incompatible.gif | Incompatible}} |
 the tests fail or error out.
 
 ----
-\\ URL: http://trac.edgewall.org/
-\\ Category: Web Applications
-\\ Compatible: {{incompatible.gif | Incompatible}}
-==== Hard Dependencies
- * [[genshi | Genshi]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}
- * [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}}
-==== Soft Dependencies
- * [[http://babel.edgewall.org/ | Babel]] {{unknown.gif | Compatibility Unknown}}
- * [[bazaar | Bazaar]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}
- * [[docutils | Docutils]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[mysql-python | MySQL-Python (MySQLdb)]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[psycopg2 | Psycopg2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[pygments | Pygments]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[http://code.google.com/p/pysqlite/ | pysqlite (sqlite3)]] {{compatible.gif | Compatible}}
- * [[pytz | pytz]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
- * [[http://subversion.apache.org/ | Subversion (svn)]] {{incompatible.gif | Incompatible}}
+| URL:| http://trac.edgewall.org/|
+| Category: | Web Applications|
+| Compatible: | {{incompatible.gif | Incompatible}}|
+
+|= Hard Dependencies|
+| [[genshi | Genshi]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}|
+| [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}} |
+
+|= Soft Dependencies |
+| [[http://babel.edgewall.org/ | Babel]] {{unknown.gif | Compatibility Unknown}} |
+| [[bazaar | Bazaar]] {{incompatible.gif | Incompatible}} {{moreinfo.gif | More Information}}|
+| [[docutils | Docutils]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[mysql-python | MySQL-Python (MySQLdb)]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[psycopg2 | Psycopg2]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[pygments | Pygments]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[http://code.google.com/p/pysqlite/ | pysqlite (sqlite3)]] {{compatible.gif | Compatible}} |
+| [[pytz | pytz]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|
+| [[http://subversion.apache.org/ | Subversion (svn)]] {{incompatible.gif | Incompatible}} |

File twisted.wiki

 for most benchmarks.
 
 ----
-\\ URL: http://twistedmatrix.com/
-\\ Category: Frameworks and application servers
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[http://pypi.python.org/pypi/zope.interface | zope.interface]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://twistedmatrix.com/|
+| Category: | Frameworks and application servers|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[http://pypi.python.org/pypi/zope.interface | zope.interface]] {{unknown.gif | Compatibility Unknown}} |

File txt2tags.wiki

 1.4.1 as with Python.
 
 ----
-\\ URL: http://txt2tags.org/
-\\ Category: Document generation
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://txt2tags.org/|
+| Category: | Document generation|
+| Compatible: | {{compatible.gif | Compatible}}|

File unittest2.wiki

 nightly.
 
 ----
-\\ URL: http://pypi.python.org/pypi/unittest2
-\\ Category: Testing/QA
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://pypi.python.org/pypi/unittest2|
+| Category: | Testing/QA|
+| Compatible: | {{compatible.gif | Compatible}}|

File virtualenv.wiki

 [[https://codespeak.net/issue/pypy-dev/issue604 | issues]] for Mac OSX users.
 
 ----
-\\ URL: http://virtualenv.openplans.org/
-\\ Category: Distribution, environment and install tools
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Soft Dependencies
- * [[http://packages.python.org/distribute/ | Distribute]] {{unknown.gif | Compatibility Unknown}}
- * [[http://pip.openplans.org/ | Pip]] {{compatible.gif | Compatible}}
- * [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://virtualenv.openplans.org/|
+| Category: | Distribution, environment and install tools|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Soft Dependencies |
+| [[http://packages.python.org/distribute/ | Distribute]] {{unknown.gif | Compatibility Unknown}} |
+| [[http://pip.openplans.org/ | Pip]] {{compatible.gif | Compatible}} |
+| [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}} |
 on PyPy. However, CPython is still faster for real builds.
 
 ----
-\\ URL: http://code.google.com/p/waf/
-\\ Category: Software construction (make alternatives)
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://code.google.com/p/waf/|
+| Category: | Software construction (make alternatives)|
+| Compatible: | {{compatible.gif | Compatible}}|
 CPython 2.7.
 
 ----
-\\ URL: http://pythonpaste.org/webob/
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://pythonpaste.org/webob/|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|

File webtest.wiki

 CPython 2.7.
 
 ----
-\\ URL: http://pythonpaste.org/webtest/
-\\ Category: Testing/QA
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[webob | WebOb]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}
+| URL:| http://pythonpaste.org/webtest/|
+| Category: | Testing/QA|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[webob | WebOb]] {{compatible.gif | Compatible}} {{moreinfo.gif | More Information}}|

File werkzeug.wiki

 Werkzeug is compatible with PyPy, running without any kind of issues.
 
 ----
-\\ URL: http://werkzeug.pocoo.org/
-\\ Category: Networking libraries
-\\ Compatible: {{compatible.gif | Compatible}}
+| URL:| http://werkzeug.pocoo.org/|
+| Category: | Networking libraries|
+| Compatible: | {{compatible.gif | Compatible}}|

File zc.buildout.wiki

 with PyPy.
 
 ----
-\\ URL: http://pypi.python.org/pypi/zc.buildout
-\\ Category: Distribution, environment and install tools
-\\ Compatible: {{compatible.gif | Compatible}}
-==== Hard Dependencies
- * [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}}
+| URL:| http://pypi.python.org/pypi/zc.buildout|
+| Category: | Distribution, environment and install tools|
+| Compatible: | {{compatible.gif | Compatible}}|
+
+|= Hard Dependencies|
+| [[http://pypi.python.org/pypi/setuptools | setuptools]] {{unknown.gif | Compatibility Unknown}} |