Wiki

Clone wiki

compatibility / genshi

Genshi

Genshi's test suite passes without problems using PyPy 2.2.1 (current Genshi dev version as of revision 1271). The C speedup module can not be compiled on PyPy as it uses the CPython API directly.

The test suite is significantly slower on PyPy compared to CPython: CPython is about 120% faster (CPython 2.7.5 compared to PyPy 2.2.1 on Fedora Linux 20 x86_64). However it might be that PyPy's JIT can make a difference for real-time loads.


URL:http://genshi.edgewall.org/
Category:Templating Engines
Compatible:Compatible
Soft Dependencies
Babel Compatibility Unknown
setuptools Compatibility Unknown

Updated