1. Pypy
  2. Untitled project
  3. compatibility

Wiki

Clone wiki

compatibility / jinja2

Jinja2

Jinja2 is compatible with PyPy, running without any kind of issues. All tests in its testsuite passed with PyPy 1.4.1.

In more recent PyPys (tested with Jinja2 2.6 and PyPy 1.8) test_byte_compilation fails, because by default PyPy will not import lone .pyc files (see http://readthedocs.org/docs/pypy/en/latest/config/objspace.lonepycfiles.html ). This means passing the non-default py_compile=True to compile_templates will not work.


URL:http://jinja.pocoo.org/
Category:Templating Engines
Compatible:Compatible
Soft Dependencies
Babel Compatibility Unknown
MarkupSafe Compatible More Information
setuptools Compatibility Unknown

Updated