1. PyPy
  2. PyPy project
  3. compatibility

Wiki

Clone wiki

compatibility / networkx

NetworkX

NetworkX is known to work with PyPy >= 1.6 and NetworkX >= 1.6 (current networkx-1.6rc1).

Some functionality that depends on other packages (NumPy, SciPy, Matplotlib) is unavailable.

To run the tests use

Python 2.7.1 (d8ac7d23d3ec, Aug 17 2011, 11:51:19)
[PyPy 1.6.0 with GCC 4.4.3] on linux2
>>>> import networkx
>>>> networkx.test(doctest=True, numpy=False)

URL:http://networkx.lanl.gov/
Category:Scientific libraries
Compatible:Compatible
Soft Dependencies
matplotlib Incompatible
Nose Compatible More Information
Numpy Incompatible More Information
pydot Compatible More Information
PyGraphviz Compatibility Unknown
Pyparsing Compatible More Information
PyYAML Compatible More Information
SciPy Compatibility Unknown

Updated