Commits

Armin Rigo committed 26157ff

Minor rephrasings.

Comments (0)

Files changed (3)

source/compat.txt

 title: Python compatibility
 ---
 
-PyPy implements Python language version 2.5. It supports all of the core
+PyPy implements the Python language version 2.5. It supports all of the core
 language, passing Python test suite (with minor modifications that were
-already accepted in main python in newer versions). It supports most
-of commonly used Python `standard library modules`_, list below.
+already accepted in the main python in newer versions). It supports most
+of the commonly used Python `standard library modules`_; details below.
 
-PyPy does not support `CPython C API`_, which means that third party
+PyPy does not support the `CPython C API`_, which means that third party
 libraries for python, written in C, will not work.
 
 Standard library modules supported by PyPy, in alphabetical order:
 
 Known differencies that are not going to be fixed:
 
-* PyPy does not support refcounting semantics. The code below
+* PyPy does not support refcounting semantics. The following code
   won't fill the file immediately, but only after a certain period
-  of time, when the GC will collect
+  of time, when the GC does a collection:
 
   .. syntax:: python
 
 * We don't support certain attributes that were decided to be
   implementation-dependent. For example, ``gc.get_referrers`` does not exist.
   Others may have different behavior; for example, ``gc.enable`` and
-  ``gc.disable`` are supported, but they don't enable and disable GC, but
-  instead enable and disable running of finalizers.
+  ``gc.disable`` are supported, but they don't enable and disable the GC, but
+  instead just enable and disable the running of finalizers.
 
 * You can't attach a ``__del__`` method to a class after its creation.
 

source/download.txt

 ============================================================
 
 Here are the various binaries of **PyPy 1.2** that we provide for x86 Linux,
-Mac OS/X or Windows. This is the first release of PyPy containing JIT, hence
+Mac OS/X or Windows. This is the first release of PyPy containing
+a JIT compiler, hence
 the main goal is to try this out and see how it works for you. We put
-a lot of effort into making JIT a stable piece of software and we don't
-observe crashes, however, please consider it a beta version to try things out.
+a lot of effort into making the JIT a stable piece of software and we don't
+observe crashes; however, please consider it a beta version to try things out.
 
 .. class:: download_menu
 
 
 It is also possible to translate_ a version that includes both
 sandboxing and the JIT compiler, although as the JIT is relatively
-complicated, this reduce a bit the level of confidence we can put in it.
+complicated, this reduce a bit the level of confidence we can put in
+the result.
 
 If your CPU is a 64-bit machine and you want to translate_ a 32-bit
 version of PyPy yourself, `here are hints`_.

source/features.txt

 ===========================================================
 
 **PyPy 1.2** implements **Python 2.5.** It supports all of the core
-language, passing Python test suite (with minor modifications that were
-already accepted in main python in newer versions). It supports most
-of commonly used Python standard library modules.  For known differences
+language, passing the Python test suite (with minor modifications that were
+already accepted in the main python in newer versions). It supports most
+of the commonly used Python standard library modules.  For known differences
 with CPython, see our `compatibility`_ page.  If you are interested in
 helping with 2.6, 2.7 or 3.x features, `contact us`_!