Commits

Armin Rigo committed 12d0f63

Fix

  • Participants
  • Parent commits ab178a1

Comments (0)

Files changed (1)

pypy/interpreter/pycode.py

         if sys.version_info < (2, 7):
             raise Exception("PyPy no longer supports Python 2.6 or lower")
         from pypy.interpreter.pyframe import PyFrame
-        frame = PyFrame(self.space, self, w_globals, None)
+        frame = self.space.FrameClass(self.space, self, w_globals, None)
         frame.setdictscope(w_locals)
         return frame.run()