Can not install pip with get-pip.py

Create issue
Issue #1696 resolved
Former user created an issue

From (bugs.pypy.org) by: coli

Comments (18)

  1. Former user Account Deleted

    From (bugs.pypy.org) by: coli

    I ran "pypy get-pip.py" after installing the windows binary.
    
    Downloading/unpacking pip
      Getting page https://pypi.python.org/simple/pip/
      URLs to search for versions for pip:
      * https://pypi.python.org/simple/pip/
      Analyzing links from page https://pypi.python.org/simple/pip/
        Found link https://pypi.python.org/packages/py2.py3/p/pip/pip-1.5.1-py2.py3-
    none-any.whl#md5=237164a09943d823b954bb9e1b2a8f67 (from 
    https://pypi.python.org/simple/pip/), version: 1.5.1
        Found link https://pypi.python.org/packages/py2.py3/p/pip/pip-1.5.2-py2.py3-
    none-any.whl#md5=445a893564065937c0f31ac2cc8e2f35 (from 
    https://pypi.python.org/simple/pip/), version: 1.5.2
        Found link https://pypi.python.org/packages/py2.py3/p/pip/pip-1.5.3-py2.py3-
    none-any.whl#md5=78126f6352f3d5f29d077be0aa7f9efa (from 
    https://pypi.python.org/simple/pip/), version: 1.5.3
        Found link https://pypi.python.org/packages/py2.py3/p/pip/pip-1.5.4-py2.py3-
    none-any.whl#md5=f20bc8f31e322375ce06b26d73ce7b4f (from 
    https://pypi.python.org/simple/pip/), version: 1.5.4
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.2.1.tar.gz#md5=d2af655c1a87e03799442d045c1d6743 (from 
    https://pypi.python.org/simple/pip/), version: 0.2.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.2.tar.gz#md5=9eda07c8be7105aa774c7eb51c023294 (from 
    https://pypi.python.org/simple/pip/), version: 0.2
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.3.1.tar.gz#md5=78102ddbb040a183dd361b5d432cdf88 (from 
    https://pypi.python.org/simple/pip/), version: 0.3.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.3.tar.gz#md5=8fccb5b49c6377cbfb1949ccd7be43b3 (from 
    https://pypi.python.org/simple/pip/), version: 0.3
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.4.tar.gz#md5=b45714d04f8fd38fe8e3d4c7600b91a2 (from 
    https://pypi.python.org/simple/pip/), version: 0.4
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.5.1.tar.gz#md5=d4bdaa5f5f5bf8c6263ace75a0882232 (from 
    https://pypi.python.org/simple/pip/), version: 0.5.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.5.tar.gz#md5=63eed8673e40628534cc0aa9c98e8f3d (from 
    https://pypi.python.org/simple/pip/), version: 0.5
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.6.1.tar.gz#md5=7560e3055c66afb99ac4a7892389a237 (from 
    https://pypi.python.org/simple/pip/), version: 0.6.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.6.2.tar.gz#md5=9a43e0a2ce8833069f41c347932bdb25 (from 
    https://pypi.python.org/simple/pip/), version: 0.6.2
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.6.3.tar.gz#md5=0602fa9179cfaa98e41565d4a581d98c (from 
    https://pypi.python.org/simple/pip/), version: 0.6.3
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.6.tar.gz#md5=083ff408ca5314cf0561ff79a048cd9a (from 
    https://pypi.python.org/simple/pip/), version: 0.6
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.7.1.tar.gz#md5=420c83ad67bdcb542f772eb64392cce6 (from 
    https://pypi.python.org/simple/pip/), version: 0.7.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.7.2.tar.gz#md5=cfe73090aaa0d3b0c104179a627859d1 (from 
    https://pypi.python.org/simple/pip/), version: 0.7.2
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.7.tar.gz#md5=8d4b4f7266fe0808569182e6832d74ac (from 
    https://pypi.python.org/simple/pip/), version: 0.7
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.8.1.tar.gz#md5=5d40614774781b118dd3f10c0d038cbc (from 
    https://pypi.python.org/simple/pip/), version: 0.8.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.8.2.tar.gz#md5=df1eca0abe7643d92b5222240bed15f6 (from 
    https://pypi.python.org/simple/pip/), version: 0.8.2
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.8.3.tar.gz#md5=0603337a81f83df2b1d2f1151565efac (from 
    https://pypi.python.org/simple/pip/), version: 0.8.3
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    0.8.tar.gz#md5=468d9adc309f33ad51cee38f0d455429 (from 
    https://pypi.python.org/simple/pip/), version: 0.8
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.0.1.tar.gz#md5=28dcc70225e5bf925532abc5b087a94b (from 
    https://pypi.python.org/simple/pip/), version: 1.0.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.0.2.tar.gz#md5=47ec6ff3f6d962696fe08d4c8264ad49 (from 
    https://pypi.python.org/simple/pip/), version: 1.0.2
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.0.tar.gz#md5=327fc4a03df189506966e15021730550 (from 
    https://pypi.python.org/simple/pip/), version: 1.0
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.1.tar.gz#md5=62a9f08dd5dc69d76734568a6c040508 (from 
    https://pypi.python.org/simple/pip/), version: 1.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.2.1.tar.gz#md5=db8a6d8a4564d3dc7f337ebed67b1a85 (from 
    https://pypi.python.org/simple/pip/), version: 1.2.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.2.tar.gz#md5=99e44d1d7f88b182459e7c19c45aee9f (from 
    https://pypi.python.org/simple/pip/), version: 1.2
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.3.1.tar.gz#md5=cbb27a191cebc58997c4da8513863153 (from 
    https://pypi.python.org/simple/pip/), version: 1.3.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.3.tar.gz#md5=918559b784e2aca9559d498050bb86e7 (from 
    https://pypi.python.org/simple/pip/), version: 1.3
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.4.1.tar.gz#md5=6afbb46aeb48abac658d4df742bff714 (from 
    https://pypi.python.org/simple/pip/), version: 1.4.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.4.tar.gz#md5=ca790be30004937987767eac42cfa44a (from 
    https://pypi.python.org/simple/pip/), version: 1.4
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.5.1.tar.gz#md5=4678c2ae5cce4e9234c3923d7dcb32f0 (from 
    https://pypi.python.org/simple/pip/), version: 1.5.1
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.5.2.tar.gz#md5=5da30919f732d68b1c666e484e7676f5 (from 
    https://pypi.python.org/simple/pip/), version: 1.5.2
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.5.3.tar.gz#md5=78871c5f84ea5fca61900347ce7864ad (from 
    https://pypi.python.org/simple/pip/), version: 1.5.3
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.5.4.tar.gz#md5=834b2904f92d46aaa333267fb1c922bb (from 
    https://pypi.python.org/simple/pip/), version: 1.5.4
        Found link https://pypi.python.org/packages/source/p/pip/pip-
    1.5.tar.gz#md5=6969b8a8adc4c7f7c5eb1707118f0686 (from 
    https://pypi.python.org/simple/pip/), version: 1.5
        Skipping https://github.com/pypa/pip/tarball/develop#egg=pip-dev (from 
    https://pypi.python.org/simple/pip/) because it is externally hosted.
      Using version 1.5.4 (newest of versions: 1.5.4, 1.5.4, 1.5.3, 1.5.3, 1.5.2, 
    1.5.2, 1.5.1, 1.5.1, 1.5, 1.4.1, 1.4, 1.3.1, 1.3, 1.2.1, 1.2, 1.1, 
    1.0.2, 1.0.1, 1.0, 0.8.3, 0.8.2, 0.8.1, 0.8, 0.7.2, 0.7.1, 0.7, 0.6.3, 0.6.2, 
    0.6.1, 0.6, 0.5.1, 0.5, 0.4, 0.3.1, 0.3, 0.2.1, 0.2)
    Cleaning up...
      Removing temporary dir c:\users\owl\appdata\local\temp\pip_build_owl...
    Exception:
    Traceback (most recent call last):
      File "c:\users\owl\appdata\local\temp\tmpa8zmqn\pip.zip\pip/basecommand.py", 
    line 122, in main
        status = self.run(options, args)
      File 
    "c:\users\owl\appdata\local\temp\tmpa8zmqn\pip.zip\pip/commands/install.py", 
    line 274, in run
        requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, 
    bundle=self.bundle)
      File "c:\users\owl\appdata\local\temp\tmpa8zmqn\pip.zip\pip/req.py", line 
    1173, in prepare_files
        self.unpack_url(url, location, self.is_download)
      File "c:\users\owl\appdata\local\temp\tmpa8zmqn\pip.zip\pip/req.py", line 
    1320, in unpack_url
        retval = unpack_http_url(link, location, self.download_cache, 
    self.download_dir, self.session)
      File "c:\users\owl\appdata\local\temp\tmpa8zmqn\pip.zip\pip/download.py", line 
    555, in unpack_http_url
        resp = session.get(target_url, stream=True)
      File 
    "c:\users\owl\appdata\local\temp\tmpa8zmqn\pip.zip\pip/_vendor/requests/sessions
    .py", line 395, in get
        return self.request('GET', url, **kwargs)
      File "c:\users\owl\appdata\local\temp\tmpa8zmqn\pip.zip\pip/download.py", line 
    237, in request
        return super(PipSession, self).request(method, url, *args, **kwargs)
      File 
    "c:\users\owl\appdata\local\temp\tmpa8zmqn\pip.zip\pip/_vendor/requests/sessions
    .py", line 383, in request
        resp = self.send(prep, **send_kwargs)
      File 
    "c:\users\owl\appdata\local\temp\tmpa8zmqn\pip.zip\pip/_vendor/requests/sessions
    .py", line 486, in send
        r = adapter.send(request, **kwargs)
      File 
    "c:\users\owl\appdata\local\temp\tmpa8zmqn\pip.zip\pip/_vendor/requests/adapters
    .py", line 378, in send
        raise ConnectionError(e)
    ConnectionError: HTTPSConnectionPool(host='pypi.python.org', port=443): Max 
    retries exceeded with url: /packages/py2.py3/p/pip/pip-1.5.4-py2.py3-none-
    any.whl (Caused by <class 'httplib.BadStatusLine'>: '')
    
  2. Armin Rigo
    Can you double-check the version numbers?  I'm getting exactly the same bug
    whenever I try (on Linux, various machines) pypy 2.2; but this seems to have
    been resolved in 2.2.1.
    
  3. mattip
    I am getting the BadStatusLine error for the second call to the ssl wrapped 
    socket on many versions of win32, including latest nightly. It seems we don't 
    actually have a test (yet) for two consecutive calls to a ssl server where the 
    first one returns 1265 bytes of payload. So far I have put debug printing into 
    httplib.py but cannot find why the second call is timimg out, The connection 
    still has _connected==True, but that doesn't mean much apparantly
    
  4. Armin Rigo
    Hi Matti!  If you give up on this one, please remember to post the small example
    you came up with (two consecutive calls to ssl) so that we can take over.  But
    thanks a lot for looking into it!
    
  5. mattip
    I get ssltimeout on the stdlib test_ftplib TestTLS_FTPClassMixin tests, as far 
    back as 2.2.1 on win32.
    Adding self.client.debugging = 1 jsut before self.client.prot_p() yields:
    *cmd* 'PBSZ 0'
    *resp* '200 PBSZ=0 successful.'
    *cmd* 'PROT P'
    SSLError: SSLError...med out')
    
    cpython 2.7.5 passes the test with no errors.
    
  6. mattip
    I have boiled this down to a 10 line test on using login(), passes on cpython, 
    fails on pypy win32. It would be nice to be able to run this test untranslated. 
    Naively trying pyinteractive with
    
    c:\Python27\python.exe pypy\bin\pyinteractive.py --withmod-_ssl --withmod-
    _socket --withmod-struct --withmod-binascii --withmod-select --withmod-time --
    withmod-signal --withmod-thread c:\temp\logintest.py
    
    unfortunately crashes before it runs the test
    
  7. mattip
    coli, please try again with the latest nightly from
    http://buildbot.pypy.org/nightly/trunk/pypy-c-jit-latest-win32.zip
    It seems to install all the pieces for me, but then fails.
    
  8. Former user Account Deleted

    From (bugs.pypy.org) by: coli

    Yup, getting a different error now:
    
    
      File "c:\users\owl\appdata\local\temp\tmpxqt7hj\pip.zip\pip/basecommand.py", line 122, in main
        status = self.run(options, args)
      File "c:\users\owl\appdata\local\temp\tmpxqt7hj\pip.zip\pip/commands/install.py", line 279, in run
        requirement_set.install(install_options, global_options, root=options.root_path)
      File "c:\users\owl\appdata\local\temp\tmpxqt7hj\pip.zip\pip/req.py", line 1380, in install
        requirement.install(install_options, global_options, *args, **kwargs)
      File "c:\users\owl\appdata\local\temp\tmpxqt7hj\pip.zip\pip/req.py", line 664, in install
        self.move_wheel_files(self.source_dir, root=root)
      File "c:\users\owl\appdata\local\temp\tmpxqt7hj\pip.zip\pip/req.py", line 894, in move_wheel_files
        pycompile=self.pycompile,
      File "c:\users\owl\appdata\local\temp\tmpxqt7hj\pip.zip\pip/wheel.py", line 308, in move_wheel_files
        generated.extend(maker.make(spec))
      File "c:\users\owl\appdata\local\temp\tmpxqt7hj\pip.zip\pip/_vendor/distlib/scripts.py", line 305, in make
        self._make_script(entry, filenames, options=options)
      File "c:\users\owl\appdata\local\temp\tmpxqt7hj\pip.zip\pip/_vendor/distlib/scripts.py", line 209, in _make_script
        self._write_script(scriptnames, shebang, script, filenames, ext)
      File "c:\users\owl\appdata\local\temp\tmpxqt7hj\pip.zip\pip/_vendor/distlib/scripts.py", line 151, in _write_script
        launcher = self._get_launcher('t')
      File "c:\users\owl\appdata\local\temp\tmpxqt7hj\pip.zip\pip/_vendor/distlib/scripts.py", line 284, in _get_launcher
        result = finder(distlib_package).find(name).bytes
    AttributeError: 'NoneType' object has no attribute 'bytes'
    
  9. mattip
    result = finder(distlib_package).find(name)
    the wheel installer is looking for name=t32.exe deep in a zipfile (pip.zip)
    \pip.zip\pip\_vendor\distlib\t32.exe
    and not finding it.
    
    If I expand the pip.zip, intsallation proceeds flawlessly. I'm not sure where to 
    look next, perhaps something is wrong with zip directories and pypy win32?
    
  10. Former user Account Deleted

    From (bugs.pypy.org) by: coli

    This may be a bug at distlib, I found 
    https://bitbucket.org/pypa/distlib/issue/40/using-distlibscripts-from-within-a-
    zipfile
    
    it was closed as fixed though
    
  11. mattip
    The source of the distlib failure is in zipimport caching file paths with unix '/' 
    path.sep instead of windows '\\' pathsep. This makes the ZipResourceFinder 
    unhappy. I expanded the test_zip_directory_cache test to check, it currently fails 
    on windows.
    
  12. Ludovic Gasc

    +1 for that: It's complicated to install stuff with pypy3, I use setup.py + custom sites-packages to by-pass this limitation.

  13. Log in to comment