List of build dependencies for Ubuntu 16.04 has wrong package names

Create issue
Issue #2676 resolved
bmerry created an issue

The page at http://doc.pypy.org/en/latest/build.html#install-build-time-dependencies has a list of packages to install for Ubuntu 12.04 to 16.04, which does not match the actual packages available on 16.04: - libz-dev should be zlib1g-dev - libncurses-dev should be libncurses5-dev - libncursesw-dev should be libncursesw5-dev

In the first two cases apt-get automatically chooses the correct package, but in the final case it does not.

Comments (2)

  1. bmerry reporter

    If I'm not mistaken, this is exactly the difference between the lists recommended for 16.04 versus 17.04 - so I suggest changing "(like 17.04)" to "(16.04 onwards)" and "(12.04 to 16.04)" to "(12.04 to 15.10)", assuming that 16.04 is actually where the transition happened.

  2. Log in to comment