invoking pypy3-v6.0.0 by tox on Windows 10 raises error

Issue #2928 resolved
Manfred Moitzi
created an issue

Setup of virtual pypy3 environment with tox on Windows 10 raises an error:

  • CPython 3.7.0 on Windows 10
  • tox: 3.5.3
  • virtualenv: 16.1.0
actionid: pypy3
msg: getenv
cmdargs: "'c:\\python37\\python.exe' -m virtualenv --python 'C:\\pypy3-v6.0.0-win32\\pypy3.EXE' pypy3"

Using base prefix 'C:\\pypy3-v6.0.0-win32'
New pypy executable in D:\Source\ezdxf.git\.tox\pypy3\bin\pypy3.EXE
Also creating executable in D:\Source\ezdxf.git\.tox\pypy3\bin\pypy.EXE
Installing setuptools, pip, wheel...

  Complete output from command D:\Source\ezdxf.git\.tox\pypy3\bin\pypy3.EXE - setuptools pip wheel:
  RPython traceback:
  File "pypy_interpreter.c", line 42299, in BuiltinCode1_fastcall_1
  File "pypy_module_posix.c", line 4913, in get_terminal_size
Traceback (most recent call last):
  File "<stdin>", line 27, in <module>
  File "c:\python37\lib\site-packages\virtualenv_support\pip-18.1-py2.py3-none-any.whl\pip\_internal\__init__.py", line 64, in main
    cmd_name, cmd_args = parse_command(args)
  File "c:\python37\lib\site-packages\virtualenv_support\pip-18.1-py2.py3-none-any.whl\pip\_internal\cli\main_parser.py", line 58, in parse_command
    parser = create_main_parser()
  File "c:\python37\lib\site-packages\virtualenv_support\pip-18.1-py2.py3-none-any.whl\pip\_internal\cli\main_parser.py", line 28, in create_main_parser
    'formatter': UpdatingDefaultsHelpFormatter(),
  File "c:\python37\lib\site-packages\virtualenv_support\pip-18.1-py2.py3-none-any.whl\pip\_internal\cli\parser.py", line 26, in __init__
    kwargs['width'] = get_terminal_size()[0] - 2
  File "c:\python37\lib\site-packages\virtualenv_support\pip-18.1-py2.py3-none-any.whl\pip\_internal\utils\compat.py", line 217, in get_terminal_size
    return tuple(shutil.get_terminal_size())
  File "D:\Source\ezdxf.git\.tox\pypy3\lib-python\3\shutil.py", line 1078, in get_terminal_size
    size = os.get_terminal_size(sys.__stdout__.fileno())
SystemError: unexpected internal exception (please report a bug): <WindowsError object at 0x60dace8>; internal traceback was dumped to stderr
----------------------------------------
...Installing setuptools, pip, wheel...done.
Traceback (most recent call last):
  File "c:\python37\lib\site-packages\virtualenv.py", line 2462, in <module>
    main()
  File "c:\python37\lib\site-packages\virtualenv.py", line 762, in main
    symlink=options.symlink,
  File "c:\python37\lib\site-packages\virtualenv.py", line 1015, in create_environment
    install_wheel(to_install, py_executable, search_dirs, download=download)
  File "c:\python37\lib\site-packages\virtualenv.py", line 968, in install_wheel
    call_subprocess(cmd, show_stdout=False, extra_env=env, stdin=SCRIPT)
  File "c:\python37\lib\site-packages\virtualenv.py", line 854, in call_subprocess
    raise OSError("Command {} failed with error code {}".format(cmd_desc, proc.returncode))
OSError: Command D:\Source\ezdxf.git\.tox\pypy3\bin\pypy3.EXE - setuptools pip wheel failed with error code 1
Running virtualenv with interpreter C:\pypy3-v6.0.0-win32\pypy3.EXE

Comments (3)

  1. Log in to comment