Commits

Georg Brandl committed 2a66153

Closes #793: Fix docutils version references.

  • Participants
  • Parent commits a24e93f
  • Branches stable

Comments (0)

Files changed (2)

doc/ext/appapi.rst

      <http://docutils.sourceforge.net/docs/howto/rst-directives.html>`_ for
      details.
 
-     The directive class normally must inherit from the class
-     ``docutils.parsers.rst.Directive``.  When writing a directive for usage in
-     a Sphinx extension, you inherit from ``sphinx.util.compat.Directive``
-     instead which does the right thing even on docutils 0.4 (which doesn't
-     support directive classes otherwise).
+     The directive class must inherit from the class
+     ``docutils.parsers.rst.Directive``.
 
    For example, the (already existing) :rst:dir:`literalinclude` directive would be
    added like this:
 -------------
 
 Sphinx needs at least **Python 2.4** or **Python 3.1** to run, as well as the
-docutils_ and Jinja2_ libraries.  Sphinx should work with docutils version 0.5
+docutils_ and Jinja2_ libraries.  Sphinx should work with docutils version 0.7
 or some (not broken) SVN trunk snapshot.  If you like to have source code
 highlighting support, you must also install the Pygments_ library.