Issue #5 resolved

Razen cant find libpyside files in Mint 14

Sergey Kliver
created an issue

OS: Linux Mint 14

libpyside1.1 and libpyside-dev packages are installed

Razen terminal output:

Traceback (most recent call last):

File "Console.py", line 29, in <module>

File "razen.py", line 4, in <module>

File "rzn/ui/mainapp.py", line 2, in <module>

File "rzn/ui/qt.py", line 10, in <module>

File "ExtensionLoader_PySide_QtCore.py", line 12, in <module>

ImportError: libpyside-python2.7.so.1.1: cannot open shared object file: No such file or directory

Comments (7)

  1. Anonymous

    This might be duplicate. I also had the same error, having that library installed, the reason is suprizing but simple

    mateusz@astro:~/razen$ file razen

    razen: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.26, BuildID[sha1]=0xac4850ec7c8a5bebb6580de798abb84bf7dbc41d, stripped

    Can you provide 64bit binaries ?

  2. Sergey Kliver reporter

    Forgot to write, that also tried Razen with 64-bit system.

    Unfortunately, there is problem with libqt4-opengl library in 709th build:

    ragnvald ~ # '/root/Repositories/downloaded/Razen/razen/razen'
    Traceback (most recent call last):
      File "Console.py", line 27, in <module>
      File "razen.py", line 4, in <module>
      File "rzn/ui/mainapp.py", line 2, in <module>
      File "rzn/ui/qt.py", line 10, in <module>
      File "ExtensionLoader_PySide_QtOpenGL.py", line 11, in <module>
    ImportError: libQtOpenGL.so.4: cannot open shared object file: No such file or directory
    

    with libqt4-opengl:i386 installed:

    ragnvald ~ # '/root/Repositories/downloaded/Razen/razen/razen'
    QWidget: Must construct a QApplication before a QPaintDevice
    Aborted (core dumped)
    
  3. Log in to comment