Support for platform armv7l (cubox i4 pro)

Create issue
Issue #23 open
Former user created an issue

Hola!

It would be great if you can add support for the armv7l architecture (hardware is cubox i4 pro).

From what I've understood ARMv6 and ARMv7 are not binary compatible, so I'll guess that you must add the correct libs to the plugin in order to make it work?

Please let me know if I can help out by testing in some way.

Thanks in advance!

Comments (29)

  1. Jeroenski74

    Hello,

    Just received the Cubox i4 pro and directly installed spotlight, but I'm getting the error: " I tried to reboot, alter the password and reboot, but nothing works. I hope this all is the result of what's mentioned in the first post and I'm also willing to beta test.

  2. Dariusz Dariusz repo owner

    I'm going to add armv7 libs this weekend. I'll publish experimental release. I'll need your tests because I lack this kind of hardware.

  3. Dariusz Dariusz repo owner

    jeroenski74, could you please paste me your xbmc log after Spotlight crash/error? I need some entries for device/architecture identification.

  4. Jeroenski74

    Hi Sorry I was at a birthday, just got home. I access my Cubox via Filezilla, but cannot find the location of the log file (root/.xbmc/temp/xbmc.log) not even with hidden files on. I'm using the lunix Geexbox image.

  5. Bjorn Eriksson

    This is great news :) thanks for your effort. I run GeexBox on mine.

    jeroenski74:Think you need to turn on debug in xbmc.

  6. Jeroenski74

    I did turn debugging on but I couldn't find the location via Filezilla and not on the mcsd directly either, can you help me out here midget express?

  7. midget express

    I think I had the same problem with not being able to list all directories and files via FTP access. Can you try to access the system via SCP or SSH, use Putty or WinSCP? Look here for reference: http://www.geexbox.org/geexbox-advanced-configuration-login-and-administration/

    Unfortunately I don't have remote access to my GeeXboX at the moment but I'll can look into it as soon as I get some minutes over at home if you still have no success in finding the logs. Good luck!

  8. Dariusz Dariusz repo owner

    Ah. This particular error shows that internal port is already in use. Please go to advanced settings and change internal port to some other number. As this maybe is not the only problem I'll prepare a build with armv7 lib from Spotify and we'll see how it will go.

  9. Jeroenski74

    Hi, I have installed the zip and don't know if this is the reason, but my Xbmc keeps on soft rebooting (short black screen and home screen alternating) I'm gonna install the original image and will try again

  10. Jeroenski74

    I want too, but it was not yet in debug mode and now I cannot do anything anymore but resetting every second ;-)

  11. Dariusz Dariusz repo owner

    I don't know why but this log is incomplete or something. There's no error from spotlight in it.

  12. Jeroenski74

    Second try, I have reinstalled the geexbox image, installed the experimental plugin, changed the port to 8001, tested multiple times (all errno 111) changed it back to 8000 (empty error) changed it to 8082 (errno 111) Log: http://pastebin.com/SYgujcHu

    When I reboot, xbmx will soft reboot endlessly after installing the experimental version, not with the previous.

  13. Jan Rábik

    Hi, I had exactly the same problem. I have cubox i2, geexbox gotham, spotlight 1.2.0. At first, I had to change the port (in my case to 8008), than Errno 111. Inspired by https://bitbucket.org/re/spotlight/issue/18/errrno-111-connection-refused#comment-9929904 I changed in LibLoader.py

            if architecture.startswith('armv6'):
                return Architecture.ARMV6
    

    to

            if architecture.startswith('arm'):
                return Architecture.ARMV6
    

    and it started to work (but there was a crash later, after about an hour of play, not sure why).

  14. Samuli Sorvakko

    Hello, this experimental package does not seem to work on my Cubox i4Pro. :/ I get an errno 111 (Conenction refused) and, after perusing the log, I find the following:

    11:37:46 T:1721246784   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Pyt
    hon callback/script returned the following error<--
                                                 - NOTE: IGNORING THIS CAN LEAD TO 
    MEMORY LEAKS!
                                                Error Type: <type 'exceptions.TypeE
    rror'>
                                                Error Contents: incompatible types,
     LP_callbacks instance instead of LP_callbacks instance
                                                Traceback (most recent call last):
                                                  File "/storage/.kodi/addons/plugin.audio.spotlight/server_addon.py", line 29, in <module>
                                                    Server().start_rpc_server()
                                                  File "/storage/.kodi/addons/plugin.audio.spotlight/spotlight/service/Server.py", line 45, in __init__
                                                    self.set_up_session()
                                                  File "/storage/.kodi/addons/plugin.audio.spotlight/spotlight/service/Server.py", line 105, in set_up_session
                                                    self.session = SessionFactory(c
    allbacks, self.settings).create_session()
                                                  File "/storage/.kodi/addons/plugin.audio.spotlight/spotlight/service/session/SessionFactory.py", line 43, in cre
    ate_session
                                                    initially_unload_playlists=False,
                                                  File "/storage/.kodi/addons/plugin.audio.spotlight/resources/libs/PyspotifyCtypes-0.6-py2.4.egg/spotify/session.py", line 307, in __init__
                                                    config = _session.config(*args)
                                                TypeError: incompatible types, LP_callbacks instance instead of LP_callbacks instance
                                                -->End of Python script error repor
    t<--
    

    Which seems somewhat odd. Is there something I'd need to do for Ctypes to work properly?

    My box is, as said, a CuBox i4Pro, with the following details:

    # uname -a
    Linux LivingPi 3.14.25 #1 SMP Fri Dec 26 03:23:03 CET 2014 armv7l GNU/Linux
    
    OpenELEC (official) - Version: 5.0.0
    

    Please do ask if you need any further details! I'm not averse to a bit of Python coding but am not at all familiar with ctypes...

  15. Samuli Sorvakko

    Aaand after allowing OpenELEC to update to 5.0.2 the standard release with Siavash Safi's commit 5e1b394 manually patched in seems to work at least to some degree. I'll try the proper armv7 binaries next.

  16. Log in to comment