Sound drops out after 11-13 seconds

Create issue
Issue #33 new
Jim Henderson created an issue

I've installed the spotlight plugin on OpenELEC 4.0.5 (running Gotham) installed on a Raspberry Pi, and the navigation generally works well, but after about 11-13 seconds, the audio stops playing, though the track time keeps increasing.

What information would be useful to diagnose this issue, or is it a known issue? I wasn't able to locate an open issue that described what I'm seeing.

Thanks

Comments (15)

  1. Mika Hyttinen

    Same problem here on HTPC, tested with OpenELEC and Ubuntu 14.04. No audio issues with Windows 8.1 however.

  2. chimosh .

    Same problem. Sound stops playing after 4-5mins for me, usual after a track has finished playing in an album.

    Using XMBC stand-alone install.

  3. Dariusz Dariusz repo owner

    If unchecking "Search for embedded lyrics" in the lyrics plugin doesn't help you may try completely uninstalling the lyrics plugin.

  4. Jim Henderson reporter

    I don't actually have the lyrics plugin installed, so that's probably not the issue I'm seeing. I don't know XBMC/OpenELEC well enough to know what logs I should be looking at, so if someone can point me at what information would help identify the problem, I'll be happy to provide that info.

  5. Matthew Thode

    Can you try to not have the song playing UI come up? I've found that helps, want to see if others can reproduce.

  6. Matthew Thode

    still failed, when it is on the home screen it's good, but once it switched to the visualizer it got sad again, disabling everything I can of cu-lyrics (it's built into aeon-mq's dependancies).

  7. Matthew Thode

    seems good so far... going to say at this point to disable all of cu-lyrics' searching and the artwork for music videos, that seems good for now...

  8. Jim Henderson reporter

    Thanks, Matthew - I've just checked my setup, though, and I'm not using either of those plugins (I've checked the entire system and I have no plugins by those names).

  9. Matthew Thode

    How about artist slideshow? that may be doing it as well, not sure though. and I've found using the search to be faster then manually going through the addons.

  10. graag

    In my case (Frodo running on OpenSUSE) I've noticed that after skipping a track marked as [not available] playback will continue with the next+1 track and will go silent after few seconds (after buffer runs out)? with playback progress still updating.

    Could you verify if there is a correlation with [not available] tracks?

    I created a pull request #4 with a workaround that works for me.

  11. bop bruce

    Have the same problem, but I suspect it is not strictly spotlight issue. I see exactly the same behavior when using spotimc - possibly the problem is with libspotify core or xbmc itself (or other plugins)? I run XBMC 13.2 on Win7 HTPC.

    P.S. I have used spotimc for some time now (> 0.5 year), and I have never experienced such problems before.

  12. Cyrano Levuser

    The music always stops after a couple of seconds when the lyrics add-on CU LRC lyrics is enabled with option "embedded lyrics" switched on. A workaround is to disable embedded lyrics in that add-on. The bug is actually in Spotlight, as Spotify doesn't allow to get the stream 2 times (one for the music, one for the lyrics). Also other Spotify addons had the same issue (Spotimc fixed it in beta5) which required a change in both Spotimc and CU LRC Lyrics.

    Please change the source code of Spotlight by setting the MusicPlayer.Property(do_not_analyze) to 'true'. this will tell cu lrc lyrics to skip searching for embedded lyrics.

    https://github.com/ronie/script.cu.lrclyrics

  13. Log in to comment