Error 10061 "No connection could be made because the target machine actively refused it"

Create issue
Issue #4 resolved
Former user created an issue

Hi!

I am on Gotham and get a script error when starting XBMC, but I can still launch the script. However when I try to search, enter playlists or stared items I gets an error 10061 "No connection could be made because the target machine actively refused it"

I have tired to reset my settings that was suggested in an other issue thread, but it does not seems to help.

Debug log: http://pastebin.com/ChZNXwik

Comments (9)

  1. Dariusz Dariusz repo owner
    • changed status to open

    Hi, It looks like an issue with a platform/OS detection on Gotham and on your machine.

    You are using Windows 32-bit which should be fine. Perhaps XBMC changed the way how it reports about OS and machine architecture and add-on couldn't detect it.

    I'm opening an issue and will test it on Gotham/Windows.

    Thx, Re

  2. Marcus Arvidsson

    Thanks for your reply! Just to clarify, Im using Windows 64, not 32-bit. This might be an issue, as you say, since I saw this being reported as an issue on OSX 64-bit at the XBMC forum.

    Thanks for looking in to it.

    Cheers /Marcus

  3. Marcus Arvidsson

    Yes, that fixed the issue, now it is working great!

    Thanks for your fantastic work, love this script!

  4. Peter

    I found that you had this mistake already a long time ago and apperently a patch should have fixed it but i get the same error: [Errno 10061] "No connection could be made because the target machine actively refused it"

    This is on a freshly installed win 8.1 zenbook (64 bit). Latest Gotham XBMC to date. and spotlight : plugin.audio.spotlight-1.2.0.zip

    Very glad to see you have a spotify addon for XBMC. Hope i get it to work :)

  5. Pierre Lantin

    Hello, i installed the last version of the script and i have the same problem, so the patch release 1.0.1b1 seems to be not a solution. Could you remove the status "resolved" ?

  6. Ben Hewins

    I'm also getting this error sometimes. Normally if I try to push a couple more times it works fine.

  7. Log in to comment