Commits

Toshi MARUYAMA committed 0ec9374

prevent rake task error on JRuby 1.7 (#12228)

Following is "rake db:migrate RAILS_ENV=test" output
on jruby 1.7.0 (1.9.3p203) 2012-10-22 ff1ebbe on OpenJDK Client VM 1.6.0_18-b18 [linux-i386].

<pre>
ArgumentError: file not found: db:migrate
non_options at /xxxxx/rubies/jruby-1.7.0/lib/ruby/1.9/test/unit.rb:167
map! at org/jruby/RubyArray.java:2387
non_options at /xxxxx/rubies/jruby-1.7.0/lib/ruby/1.9/test/unit.rb:146
non_options at /xxxxx/rubies/jruby-1.7.0/lib/ruby/1.9/test/unit.rb:207
process_args at /xxxxx/rubies/jruby-1.7.0/lib/ruby/1.9/test/unit.rb:52
_run at /xxxxx/rubies/jruby-1.7.0/lib/ruby/1.9/minitest/unit.rb:891
run at /xxxxx/rubies/jruby-1.7.0/lib/ruby/1.9/minitest/unit.rb:884
run at /xxxxx/rubies/jruby-1.7.0/lib/ruby/1.9/test/unit.rb:21
autorun at /xxxxx/rubies/jruby-1.7.0/lib/ruby/1.9/test/unit.rb:326
run_once at /xxxxx/rubies/jruby-1.7.0/lib/ruby/1.9/test/unit.rb:27
autorun at /xxxxx/rubies/jruby-1.7.0/lib/ruby/1.9/test/unit.rb:325
</pre>

  • Participants
  • Parent commits 4043d8a

Comments (0)

Files changed (1)

 
 group :test do
   gem "shoulda", "~> 2.11"
-  # Shoulda does not work nice on Ruby 1.9.3 and seems to need test-unit explicitely.
-  gem "test-unit", :platforms => [:mri_19]
+  # Shoulda does not work nice on Ruby 1.9.3 and JRuby 1.7.
+  # It seems to need test-unit explicitely.
+  gem "test-unit", :platforms => [:mri_19, :jruby]
   gem "mocha", "0.12.3"
 end