1. Refactor
  2. Untitled project
  3. grails-webdriver
  4. Pull requests

Pull requests

#1 Open
Repository
Deleted repository
Branch
default (88e2f0f8e001)
Repository
grails-webdriver
Branch
default

Solved errors when running grails projects on versions < 2.2

Author
  1. jsoftb
Reviewers
Description

The legacyResolve property in BuildConfig.groovy causes an error on grails < 2.2:

Error WARNING: Dependencies cannot be resolved for plugin [grails-webdriver] due to error: No signature of method: groovy.util.ConfigSlurper$_parsclosure5.legacyResolve() is applicable for argument types: (java.lang.Boolean) values: [false] (Use --stacktrace to see the full trace)

That is because the way Grails 2.2 resolves the dependencies but on Previous versions grails does not know what to do. To avoid that I have added a simple conditional strucutre. See commit 88e2f0f

Another thing is that if you want to use the plugin as inline was showing an error about importing org.openqa.selenium.* and that it was because org.seleniumhq.selenium:selenium-java:2.27.0 was not included as dependency in the plugin. Added in the commit 88e2f0f

Comments (0)